ipq40xx: convert Aruba AP-303H to DSA and enable target again
authorNick Hainke <vincent@systemli.org>
Wed, 21 Dec 2022 09:34:03 +0000 (10:34 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Thu, 29 Dec 2022 16:39:30 +0000 (17:39 +0100)
The target was disabled since noone did the DSA conversion. Add the
conversion and enable it again.

Tested-by: John Walshaw <jjw@myself.com>
Signed-off-by: Bjoern Dobe <bjoern@dobecom.de>
Signed-off-by: Nick Hainke <vincent@systemli.org>
target/linux/ipq40xx/base-files/etc/board.d/02_network
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ap-303h.dts
target/linux/ipq40xx/image/generic.mk

index 74f39ef6de965a6c423122f660b1293a5a782bcd..bceb434bffde579dc8fba535afedb196106ad4c8 100644 (file)
@@ -69,6 +69,7 @@ ipq40xx_setup_interfaces()
        mikrotik,wap-r-ac)
                ucidef_set_interface_lan "sw-eth1 sw-eth2"
                ;;
+       aruba,ap-303h|\
        netgear,rbr50|\
        netgear,rbs50|\
        netgear,srr60|\
index 7978f90eb48fde1e7896c684bf551900d2aa18c5..fba6209d993ec90c93d1de2bf11ddacb03175ead 100644 (file)
        status = "okay";
 };
 
+&gmac {
+       status = "okay";
+};
+
+&switch {
+       status = "okay";
+};
+
+&swport2 {
+       status = "okay";
+
+       label = "lan1";
+};
+
+&swport3 {
+       status = "okay";
+
+       label = "lan2";
+};
+
+&swport4 {
+       status = "okay";
+
+       label = "lan3";
+};
+
+&swport5 {
+       status = "okay";
+
+       label = "wan";
+};
+
 &wifi0 {
        status = "okay";
        qcom,ath10k-calibration-variant = "Aruba-AP-303";
index 290581ac80a21a593df5ca670f3db5be7da70bdc..5dae52ff0ea13f572ff86bc6f882a24d8d6bb374 100644 (file)
@@ -181,8 +181,7 @@ define Device/aruba_ap-303h
        $(call Device/aruba_glenmorangie)
        DEVICE_MODEL := AP-303H
 endef
-# Missing DSA Setup
-#TARGET_DEVICES += aruba_ap-303h
+TARGET_DEVICES += aruba_ap-303h
 
 define Device/aruba_ap-365
        $(call Device/aruba_glenmorangie)