build: make sure that $(STAGING_DIR_IMAGE) exists
authorDaniel Golle <daniel@makrotopia.org>
Tue, 29 Nov 2022 15:26:25 +0000 (15:26 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Mon, 5 Dec 2022 01:28:28 +0000 (01:28 +0000)
Call 'mkdir -p $(STAGING_DIR_IMAGE)' before trying to store files in
this potentially non-existing folder.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
include/image-commands.mk

index 1f6ba1c15a47e983692a0a100721e4420476818a..41e1c9694852e60c6c2ce4d20619b9c727a492b3 100644 (file)
@@ -53,6 +53,7 @@ define Build/append-image-stage
        cp "$(BIN_DIR)/$(DEVICE_IMG_PREFIX)-$(1)" "$@.stripmeta"
        fwtool -s /dev/null -t "$@.stripmeta" || :
        fwtool -i /dev/null -t "$@.stripmeta" || :
+       mkdir -p "$(STAGING_DIR_IMAGE)"
        dd if="$@.stripmeta" of="$(STAGING_DIR_IMAGE)/$(BOARD)$(if $(SUBTARGET),-$(SUBTARGET))-$(DEVICE_NAME)-$(1)"
        dd if="$@.stripmeta" >> "$@"
        rm "$@.stripmeta"