ipq807x: don't generate factory.ubi for Buffalo WXR-5950AX12
authorINAGAKI Hiroshi <musashino.open@gmail.com>
Sat, 25 Feb 2023 00:56:27 +0000 (09:56 +0900)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 4 Mar 2023 12:12:40 +0000 (13:12 +0100)
On WXR-5950AX12, squashfs-factory.ubi is unnecessary for OpenWrt
installation and other purposes, so drop it from IMAGES and don't
generate to prevent confusion of users.

Reviewed-by: Robert Marko <robimarko@gmail.com>
Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
target/linux/ipq807x/image/generic.mk

index 88d16cc7b2b53f0a6f0cc6d5713414f0ea2dd5c6..1e74015e18d26514719ced9896ad16a137c3f66e 100644 (file)
@@ -19,13 +19,14 @@ endef
 
 define Device/buffalo_wxr-5950ax12
        $(call Device/FitImage)
-       $(call Device/UbiFit)
        DEVICE_VENDOR := Buffalo
        DEVICE_MODEL := WXR-5950AX12
        BLOCKSIZE := 128k
        PAGESIZE := 2048
        DEVICE_DTS_CONFIG := config@hk01
        SOC := ipq8074
+       IMAGES := sysupgrade.bin
+       IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
        DEVICE_PACKAGES := ipq-wifi-buffalo_wxr-5950ax12
 endef
 TARGET_DEVICES += buffalo_wxr-5950ax12