iptables: pass --disable-ipv6 is CONFIG_IPV6 is unset
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 2 Jul 2014 11:39:24 +0000 (11:39 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 2 Jul 2014 11:39:24 +0000 (11:39 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 41458

package/network/utils/iptables/Makefile

index f6db428bcbd48489a54cbd52b260ad55cf7faa0e..8266f14a3e542ae90d4da667031c47255c9d0daf 100644 (file)
@@ -369,7 +369,8 @@ CONFIGURE_ARGS += \
        --enable-devel \
        --with-kernel="$(LINUX_DIR)/user_headers" \
        --with-xtlibdir=/usr/lib/iptables \
-       --enable-static
+       --enable-static \
+       $(if $(CONFIG_IPV6),,--disable-ipv6)
 
 MAKE_FLAGS := \
        $(TARGET_CONFIGURE_OPTS) \