tools/meson: update to 1.3.2
authorRosen Penev <rosenp@gmail.com>
Wed, 21 Feb 2024 21:13:34 +0000 (13:13 -0800)
committerPaul Spooren <mail@aparcar.org>
Fri, 29 Mar 2024 22:42:22 +0000 (23:42 +0100)
Add explicit setup as implicit is deprecated.

Rename pkgconfig as no hyphen is deprecated.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
include/meson.mk
tools/meson/Makefile
tools/meson/files/openwrt-cross.txt.in
tools/meson/files/openwrt-native.txt.in

index 74c9d3dd7fa25fd1273085a97422d2841850e6ae..65716746fe1eec4aaf3ac03c8069c960eb4c3476 100644 (file)
@@ -98,6 +98,7 @@ endef
 define Host/Configure/Meson
        $(call Meson/CreateNativeFile,$(HOST_BUILD_DIR)/openwrt-native.txt)
        $(call Meson, \
+               setup \
                --native-file $(HOST_BUILD_DIR)/openwrt-native.txt \
                $(MESON_HOST_ARGS) \
                $(MESON_HOST_BUILD_DIR) \
@@ -121,6 +122,7 @@ define Build/Configure/Meson
        $(call Meson/CreateNativeFile,$(PKG_BUILD_DIR)/openwrt-native.txt)
        $(call Meson/CreateCrossFile,$(PKG_BUILD_DIR)/openwrt-cross.txt)
        $(call Meson, \
+               setup \
                --buildtype plain \
                --native-file $(PKG_BUILD_DIR)/openwrt-native.txt \
                --cross-file $(PKG_BUILD_DIR)/openwrt-cross.txt \
index 23bb393a593346988985a8a2fb14c239bfc0cb7c..96974faafe5f56399aee539829e0576f54e4deaf 100644 (file)
@@ -1,11 +1,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=meson
-PKG_VERSION:=1.2.1
+PKG_VERSION:=1.3.2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/mesonbuild/meson/releases/download/$(PKG_VERSION)
-PKG_HASH:=b1db3a153087549497ee52b1c938d2134e0338214fe14f7efd16fecd57b639f5
+PKG_HASH:=492eb450c8b073024276f916f5adbb3c4bb7e90e9e6ec124efda064f3d9b5baa
 
 PKG_MAINTAINER:=Andre Heider <a.heider@gmail.com>
 PKG_LICENSE:=Apache-2.0
index ba119150691820c1f1432c7293d132e57a394adf..836a0e51e4fb25ca3cfe9c35bcaf7dfc4ce1ccae 100644 (file)
@@ -6,7 +6,7 @@ cpp_ld = [@LD@]
 ar = '@AR@'
 strip = '@STRIP@'
 nm = '@NM@'
-pkgconfig = '@PKGCONFIG@'
+pkg-config = '@PKGCONFIG@'
 cmake = '@CMAKE@'
 python = '@PYTHON@'
 
index 48e09ece2c65898e653927facfc66fdcc0faeded..179e00b43ee18e9b000987bfa9a5b5a2eee127d9 100644 (file)
@@ -1,7 +1,7 @@
 [binaries]
 c = [@CC@]
 cpp = [@CXX@]
-pkgconfig = '@PKGCONFIG@'
+pkg-config = '@PKGCONFIG@'
 cmake = '@CMAKE@'
 python = '@PYTHON@'