tools/flex: override SUBDIRS variable with Makefile
authorMichael Pratt <mcpratt@pm.me>
Sat, 25 Mar 2023 05:01:36 +0000 (01:01 -0400)
committerChristian Marangi <ansuelsmth@gmail.com>
Thu, 4 May 2023 04:07:28 +0000 (06:07 +0200)
Instead of editing the SUBDIRS variable with a patch,
it can be overriden at the end of the command line when invoking Make.

Skip the build for po files as well, which is causing a conflict
depending on the version of gettext detected, and macros present.

Signed-off-by: Michael Pratt <mcpratt@pm.me>
tools/flex/Makefile
tools/flex/patches/100-disable-tests-docs.patch [deleted file]

index da037ae72d84b52181e28c8e46495ad922b9f4d2..86ba5a4415d3a82aaf5e9897736b465cc7e30c42 100644 (file)
@@ -21,13 +21,17 @@ include $(INCLUDE_DIR)/host-build.mk
 
 HOST_CONFIGURE_ARGS += --disable-shared
 
+define Host/Compile
+       $(call Host/Compile/Default,SUBDIRS='src tools')
+endef
+
 define Host/Install
-       $(call Host/Install/Default)
+       $(call Host/Compile/Default,install SUBDIRS='src tools')
        $(LN) flex $(STAGING_DIR_HOST)/bin/lex
 endef
 
 define Host/Uninstall
-       -$(call Host/Compile/Default,uninstall)
+       -$(call Host/Compile/Default,uninstall SUBDIRS='src tools')
 endef
 
 define Host/Clean
diff --git a/tools/flex/patches/100-disable-tests-docs.patch b/tools/flex/patches/100-disable-tests-docs.patch
deleted file mode 100644 (file)
index f7097f2..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -43,10 +43,7 @@ EXTRA_DIST = \
- SUBDIRS = \
-       src \
--      doc \
--      examples \
-       po \
--      tests \
-       tools
- # Create the ChangeLog, but only if we're inside a git working directory