sunxi: add modules for AC100 MFD and RTC
authorZoltan HERPAI <wigyori@uid0.hu>
Sun, 17 Jan 2021 22:26:33 +0000 (23:26 +0100)
committerZoltan HERPAI <wigyori@uid0.hu>
Fri, 11 Aug 2023 16:04:43 +0000 (18:04 +0200)
The X-Powers AC100 is a multi-function IC used to provide RTC
and audio codec via RSB (reduced serial bus, an Allwinner-
speciality). On some boards using the A80/A83T SoCs, aside
from the RTC functionality, the RTC is used as a clocksource
for the Ampak WiFi/BT modules.

Add modules for the core MFD support and the RTC.

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
target/linux/sunxi/modules.mk

index 8bbafe98a7b13be352de302e646d4d009d1c55b5..28ed86ba4c9f9cfead16f32a320a4d0cebfc101c 100644 (file)
@@ -2,6 +2,40 @@
 #
 # Copyright (C) 2013-2016 OpenWrt.org
 
+define KernelPackage/mfd-ac100
+    SUBMENU:=$(OTHER_MENU)
+    TITLE:=X-Powers AC100 MFD support
+    DEPENDS:=@TARGET_sunxi
+    KCONFIG:= \
+       CONFIG_MFD_AC100
+    FILES:=$(LINUX_DIR)/drivers/mfd/ac100.ko
+    AUTOLOAD:=$(call AutoLoad,50,ac100)
+endef
+
+define KernelPackage/mfd-ac100/description
+ Support for the X-Powers AC100 RTC/audio chip
+endef
+
+$(eval $(call KernelPackage,mfd-ac100))
+
+define KernelPackage/rtc-ac100
+    SUBMENU:=$(OTHER_MENU)
+    TITLE:=X-Powers AC100 RTC support
+    DEPENDS:=@TARGET_sunxi +kmod-mfd-ac100
+    $(call AddDepends/rtc)
+    KCONFIG:= \
+       CONFIG_RTC_DRV_AC100 \
+       CONFIG_RTC_CLASS=y
+    FILES:=$(LINUX_DIR)/drivers/rtc/rtc-ac100.ko
+    AUTOLOAD:=$(call AutoLoad,50,rtc-ac100)
+endef
+
+define KernelPackage/rtc-ac100/description
+ Support for the X-Powers AC100 RTC
+endef
+
+$(eval $(call KernelPackage,rtc-ac100))
+
 define KernelPackage/rtc-sunxi
     SUBMENU:=$(OTHER_MENU)
     TITLE:=Sunxi SoC built-in RTC support