kernel: bump 5.10 to 5.10.75
authorRui Salvaterra <rsalvaterra@gmail.com>
Wed, 20 Oct 2021 12:07:59 +0000 (13:07 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 20 Oct 2021 22:17:36 +0000 (00:17 +0200)
Deleted (upstreamed):
bcm27xx/patches-5.10/950-0735-xhci-guard-accesses-to-ep_state-in-xhci_endpoint_res.patch [1]

[1] https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=linux-5.10.y&id=dc3e0a20dbb9dbaa22f4a33dea34230f8c663c40

Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
18 files changed:
include/kernel-version.mk
target/linux/apm821xx/patches-5.10/802-usb-xhci-force-msi-renesas-xhci.patch
target/linux/bcm27xx/patches-5.10/950-0139-xhci-implement-xhci_fixup_endpoint-for-interval-adju.patch
target/linux/bcm27xx/patches-5.10/950-0145-xhci-add-quirk-for-host-controllers-that-don-t-updat.patch
target/linux/bcm27xx/patches-5.10/950-0355-xhci-quirks-add-link-TRB-quirk-for-VL805.patch
target/linux/bcm27xx/patches-5.10/950-0376-ARM-dts-bcm27xx-Remove-enable_headphones-setting.patch
target/linux/bcm27xx/patches-5.10/950-0438-dt-Add-a-camera-regulator-node-to-all-downstream-Pi-.patch
target/linux/bcm27xx/patches-5.10/950-0509-ARM-dts-bcm2711-Add-aliases-for-additional-SPIs.patch
target/linux/bcm27xx/patches-5.10/950-0706-ARM-dts-bcm2711-Tidy-the-HDMI-I2C-aliases.patch
target/linux/bcm27xx/patches-5.10/950-0733-usb-xhci-workaround-for-bogus-SET_DEQ_PENDING-endpoi.patch
target/linux/bcm27xx/patches-5.10/950-0735-xhci-guard-accesses-to-ep_state-in-xhci_endpoint_res.patch [deleted file]
target/linux/bcm27xx/patches-5.10/950-0736-ARM-dts-Adapt-to-upstream-changes.patch
target/linux/generic/hack-5.10/710-net-dsa-mv88e6xxx-default-VID-1.patch
target/linux/generic/hack-5.10/711-net-dsa-mv88e6xxx-disable-ATU-violation.patch
target/linux/generic/pending-5.10/760-net-dsa-mv88e6xxx-fix-vlan-setup.patch
target/linux/generic/pending-5.10/768-net-dsa-mv88e6xxx-Request-assisted-learning-on-CPU-port.patch
target/linux/ramips/patches-5.10/200-add-ralink-eth.patch
target/linux/realtek/patches-5.10/702-net-ethernet-add-support-for-rtl838x-ethernet.patch

index 6374dd67ec071437f37153a7a44958460a3a05fa..cb4f72716fd3883a00e99b3b76ed7135e6955e28 100644 (file)
@@ -7,10 +7,10 @@ ifdef CONFIG_TESTING_KERNEL
 endif
 
 LINUX_VERSION-5.4 = .155
-LINUX_VERSION-5.10 = .74
+LINUX_VERSION-5.10 = .75
 
 LINUX_KERNEL_HASH-5.4.155 = cc0c0f902748d251cb22d0e69e3b8d260c447eb0072ef853da15da6cce775038
-LINUX_KERNEL_HASH-5.10.74 = 5755a6487018399812238205aba73a2693b0f9f3cd73d7cf1ce4d5436c3de1b0
+LINUX_KERNEL_HASH-5.10.75 = 0a2b2f5fefb90773190aaef4726ac363e03992aedc424b0a57eca092d084304b
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index b9ca1aa92ba7f96ad884620bbe2f0a8e034ed2be..52198e41f44b05cebecff227b70a0c87d388e4d0 100644 (file)
@@ -13,7 +13,7 @@ produce a noisy warning.
 
 --- a/drivers/usb/host/xhci-pci.c
 +++ b/drivers/usb/host/xhci-pci.c
-@@ -265,6 +265,7 @@ static void xhci_pci_quirks(struct devic
+@@ -267,6 +267,7 @@ static void xhci_pci_quirks(struct devic
            pdev->device == 0x0015) {
                xhci->quirks |= XHCI_RESET_ON_RESUME;
                xhci->quirks |= XHCI_ZERO_64B_REGS;
index 391af473d1e2670ec43956c4d21171a80a9ffc63..e3288603747d68b4790e887fe44f6cc7030f562f 100644 (file)
@@ -119,7 +119,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
   * non-error returns are a promise to giveback() the urb later
   * we drop ownership so next owner (or urb unlink) can get it
   */
-@@ -5362,6 +5459,7 @@ static const struct hc_driver xhci_hc_dr
+@@ -5367,6 +5464,7 @@ static const struct hc_driver xhci_hc_dr
        .endpoint_reset =       xhci_endpoint_reset,
        .check_bandwidth =      xhci_check_bandwidth,
        .reset_bandwidth =      xhci_reset_bandwidth,
index aa6daa5634c96b7fe3ce5d873d117bffb7008277..0fcb3f672d8b8dc5edce32236fc8a31d76d419c8 100644 (file)
@@ -23,7 +23,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
 
 --- a/drivers/usb/host/xhci-pci.c
 +++ b/drivers/usb/host/xhci-pci.c
-@@ -274,8 +274,10 @@ static void xhci_pci_quirks(struct devic
+@@ -276,8 +276,10 @@ static void xhci_pci_quirks(struct devic
                        pdev->device == 0x3432)
                xhci->quirks |= XHCI_BROKEN_STREAMS;
  
@@ -37,7 +37,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
                pdev->device == PCI_DEVICE_ID_ASMEDIA_1042_XHCI)
 --- a/drivers/usb/host/xhci-ring.c
 +++ b/drivers/usb/host/xhci-ring.c
-@@ -556,7 +556,10 @@ void xhci_find_new_dequeue_state(struct
+@@ -562,7 +562,10 @@ void xhci_find_new_dequeue_state(struct
        struct xhci_virt_ep *ep = &dev->eps[ep_index];
        struct xhci_ring *ep_ring;
        struct xhci_segment *new_seg;
@@ -48,7 +48,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
        dma_addr_t addr;
        u64 hw_dequeue;
        bool cycle_found = false;
-@@ -594,7 +597,28 @@ void xhci_find_new_dequeue_state(struct
+@@ -600,7 +603,28 @@ void xhci_find_new_dequeue_state(struct
        hw_dequeue = xhci_get_hw_deq(xhci, dev, ep_index, stream_id);
        new_seg = ep_ring->deq_seg;
        new_deq = ep_ring->dequeue;
index 9da1275676b39852810b758cecb9dcd608798e7c..f63da53b8fbd88800ab2ff6efba8303b55be14c4 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
 
 --- a/drivers/usb/host/xhci-pci.c
 +++ b/drivers/usb/host/xhci-pci.c
-@@ -277,6 +277,7 @@ static void xhci_pci_quirks(struct devic
+@@ -279,6 +279,7 @@ static void xhci_pci_quirks(struct devic
        if (pdev->vendor == PCI_VENDOR_ID_VIA && pdev->device == 0x3483) {
                xhci->quirks |= XHCI_LPM_SUPPORT;
                xhci->quirks |= XHCI_EP_CTX_BROKEN_DCS;
@@ -32,7 +32,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
        if (pdev->vendor == PCI_VENDOR_ID_ASMEDIA &&
 --- a/drivers/usb/host/xhci-ring.c
 +++ b/drivers/usb/host/xhci-ring.c
-@@ -653,6 +653,16 @@ void xhci_find_new_dequeue_state(struct
+@@ -659,6 +659,16 @@ void xhci_find_new_dequeue_state(struct
  
        } while (!cycle_found || !td_last_trb_found);
  
index 88dfcb39f8153f6363240613ba0b25de2b575251..0098c3227dfd0c0d1045647c95ac3f7b2fbf6bf2 100644 (file)
@@ -77,7 +77,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
        aliases {
 --- a/arch/arm/boot/dts/bcm2711-rpi-4-b.dts
 +++ b/arch/arm/boot/dts/bcm2711-rpi-4-b.dts
-@@ -322,7 +322,7 @@
+@@ -323,7 +323,7 @@
  
  / {
        chosen {
index 1fc25fbea37f1d20ee00a0689456e94ad95fe0d6..ee53d7acaf6d451ad1baa0a2971b7b0d6c07fe19 100644 (file)
@@ -277,7 +277,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.com>
  &uart0 {
 --- a/arch/arm/boot/dts/bcm2711-rpi-4-b.dts
 +++ b/arch/arm/boot/dts/bcm2711-rpi-4-b.dts
-@@ -319,6 +319,7 @@
+@@ -320,6 +320,7 @@
  #include "bcm2711-rpi.dtsi"
  #include "bcm283x-rpi-csi1-2lane.dtsi"
  #include "bcm283x-rpi-i2c0mux_0_44.dtsi"
@@ -285,7 +285,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.com>
  
  / {
        chosen {
-@@ -585,6 +586,10 @@
+@@ -586,6 +587,10 @@
        pinctrl-0 = <&audio_pins>;
  };
  
index cb62ec07dd1fe5f8b917c127591796f690967788..9a6ca588c3452e3ed8a8809edf2a6c19e247e21e 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
 
 --- a/arch/arm/boot/dts/bcm2711-rpi-4-b.dts
 +++ b/arch/arm/boot/dts/bcm2711-rpi-4-b.dts
-@@ -354,6 +354,10 @@
+@@ -355,6 +355,10 @@
                i2c4 = &i2c4;
                i2c5 = &i2c5;
                i2c6 = &i2c6;
index f6a60f54d1f7457e499a91c3b18049c797b0d6f6..b931d7533d920858568e5ef8f7c87b5010582e82 100644 (file)
@@ -20,7 +20,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
 
 --- a/arch/arm/boot/dts/bcm2711-rpi-4-b.dts
 +++ b/arch/arm/boot/dts/bcm2711-rpi-4-b.dts
-@@ -349,11 +349,12 @@
+@@ -350,11 +350,12 @@
                mmc0 = &emmc2;
                mmc1 = &mmcnr;
                mmc2 = &sdhost;
@@ -34,7 +34,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
                spi3 = &spi3;
                spi4 = &spi4;
                spi5 = &spi5;
-@@ -559,13 +560,6 @@
+@@ -560,13 +561,6 @@
        pinctrl-0 = <&i2s_pins>;
  };
  
index 67a7601ac2ea5e13c44612192a5a0adf3018cf48..8a76dd1b26c8f27097db7d97e3c66e44b14614a3 100644 (file)
@@ -26,7 +26,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
 
 --- a/drivers/usb/host/xhci-ring.c
 +++ b/drivers/usb/host/xhci-ring.c
-@@ -4256,9 +4256,9 @@ void xhci_queue_new_dequeue_state(struct
+@@ -4262,9 +4262,9 @@ void xhci_queue_new_dequeue_state(struct
        }
        ep = &xhci->devs[slot_id]->eps[ep_index];
        if ((ep->ep_state & SET_DEQ_PENDING)) {
diff --git a/target/linux/bcm27xx/patches-5.10/950-0735-xhci-guard-accesses-to-ep_state-in-xhci_endpoint_res.patch b/target/linux/bcm27xx/patches-5.10/950-0735-xhci-guard-accesses-to-ep_state-in-xhci_endpoint_res.patch
deleted file mode 100644 (file)
index 9cf5aa2..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-From 9d51ba9909129465493d56a7134ce4220d2e69e9 Mon Sep 17 00:00:00 2001
-From: Jonathan Bell <jonathan@raspberrypi.com>
-Date: Mon, 16 Aug 2021 14:43:06 +0100
-Subject: [PATCH] xhci: guard accesses to ep_state in
- xhci_endpoint_reset()
-
-See https://github.com/raspberrypi/linux/issues/3981
-
-Two read-modify-write cycles on ep->ep_state are not guarded by
-xhci->lock. Fix these.
-
-Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
----
- drivers/usb/host/xhci.c | 5 +++++
- 1 file changed, 5 insertions(+)
-
---- a/drivers/usb/host/xhci.c
-+++ b/drivers/usb/host/xhci.c
-@@ -3270,10 +3270,13 @@ static void xhci_endpoint_reset(struct u
-               return;
-       /* Bail out if toggle is already being cleared by a endpoint reset */
-+      spin_lock_irqsave(&xhci->lock, flags);
-       if (ep->ep_state & EP_HARD_CLEAR_TOGGLE) {
-               ep->ep_state &= ~EP_HARD_CLEAR_TOGGLE;
-+              spin_unlock_irqrestore(&xhci->lock, flags);
-               return;
-       }
-+      spin_unlock_irqrestore(&xhci->lock, flags);
-       /* Only interrupt and bulk ep's use data toggle, USB2 spec 5.5.4-> */
-       if (usb_endpoint_xfer_control(&host_ep->desc) ||
-           usb_endpoint_xfer_isoc(&host_ep->desc))
-@@ -3359,8 +3362,10 @@ static void xhci_endpoint_reset(struct u
-       xhci_free_command(xhci, cfg_cmd);
- cleanup:
-       xhci_free_command(xhci, stop_cmd);
-+      spin_lock_irqsave(&xhci->lock, flags);
-       if (ep->ep_state & EP_SOFT_CLEAR_TOGGLE)
-               ep->ep_state &= ~EP_SOFT_CLEAR_TOGGLE;
-+      spin_unlock_irqrestore(&xhci->lock, flags);
- }
- static int xhci_check_streams_endpoint(struct xhci_hcd *xhci,
index 9bb21fda875e65c62f2467c35f0b20ba82ef0f27..6a778880e0695ecd4b2fd060a3a8e5c63115e41e 100644 (file)
@@ -191,7 +191,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
                gpios = <&virtgpio 0 0>;
 --- a/arch/arm/boot/dts/bcm2711-rpi-4-b.dts
 +++ b/arch/arm/boot/dts/bcm2711-rpi-4-b.dts
-@@ -579,13 +579,13 @@
+@@ -580,13 +580,13 @@
  };
  
  &leds {
index f301cc1e2d5119ad9324ecef1ce3c94b668bef48..03725653f950587c1ab144e6ed1c557062716255 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/dsa/mv88e6xxx/chip.c
 +++ b/drivers/net/dsa/mv88e6xxx/chip.c
-@@ -2088,6 +2088,7 @@ static int mv88e6xxx_port_fdb_add(struct
+@@ -2097,6 +2097,7 @@ static int mv88e6xxx_port_fdb_add(struct
        struct mv88e6xxx_chip *chip = ds->priv;
        int err;
  
@@ -8,7 +8,7 @@
        mv88e6xxx_reg_lock(chip);
        err = mv88e6xxx_port_db_load_purge(chip, port, addr, vid,
                                           MV88E6XXX_G1_ATU_DATA_STATE_UC_STATIC);
-@@ -2102,6 +2103,7 @@ static int mv88e6xxx_port_fdb_del(struct
+@@ -2111,6 +2112,7 @@ static int mv88e6xxx_port_fdb_del(struct
        struct mv88e6xxx_chip *chip = ds->priv;
        int err;
  
index 46a1ba1d965ea9f285e8b98c97fc3a7416882e8c..68cac73935ca6a68bbefb37668d610bac6255414 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/dsa/mv88e6xxx/chip.c
 +++ b/drivers/net/dsa/mv88e6xxx/chip.c
-@@ -2650,6 +2650,9 @@ static int mv88e6xxx_setup_port(struct m
+@@ -2659,6 +2659,9 @@ static int mv88e6xxx_setup_port(struct m
        if (dsa_is_cpu_port(ds, port))
                reg = 0;
  
index f961dc9e56269f709eae9bde9febfb978c21df11..16be95ea387e676015af1b07d08ccc4d03a686da 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: DENG Qingfang <dqfext@gmail.com>
 
 --- a/drivers/net/dsa/mv88e6xxx/chip.c
 +++ b/drivers/net/dsa/mv88e6xxx/chip.c
-@@ -2860,6 +2860,7 @@ static int mv88e6xxx_setup(struct dsa_sw
+@@ -2869,6 +2869,7 @@ static int mv88e6xxx_setup(struct dsa_sw
  
        chip->ds = ds;
        ds->slave_mii_bus = mv88e6xxx_default_mdio_bus(chip);
index 493d41224937e3cb8c6c8960c72577fd582a3143..99f42ff2128c885da6151e0cfca4b9cd62dad8a6 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: Tobias Waldekranz <tobias@waldekranz.com>
 
 --- a/drivers/net/dsa/mv88e6xxx/chip.c
 +++ b/drivers/net/dsa/mv88e6xxx/chip.c
-@@ -5422,6 +5422,7 @@ static int mv88e6xxx_register_switch(str
+@@ -5431,6 +5431,7 @@ static int mv88e6xxx_register_switch(str
        ds->ops = &mv88e6xxx_switch_ops;
        ds->ageing_time_min = chip->info->age_time_coeff;
        ds->ageing_time_max = chip->info->age_time_coeff * U8_MAX;
index 9aa8cb518055d34d870271290ae41b15bf6f64d3..90ba6e6c57259394c0bd5a5097af92e36fd3bac6 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/ethernet/Kconfig
 +++ b/drivers/net/ethernet/Kconfig
-@@ -158,6 +158,7 @@ source "drivers/net/ethernet/pasemi/Kcon
+@@ -159,6 +159,7 @@ source "drivers/net/ethernet/pasemi/Kcon
  source "drivers/net/ethernet/pensando/Kconfig"
  source "drivers/net/ethernet/qlogic/Kconfig"
  source "drivers/net/ethernet/qualcomm/Kconfig"
index 1a6668550d6bcdbcf4fe78bc361649d2228d51b7..4c5f397e10637fc6df7289031c3aeebf66cef3d6 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/ethernet/Kconfig
 +++ b/drivers/net/ethernet/Kconfig
-@@ -162,6 +162,13 @@ source "drivers/net/ethernet/rdc/Kconfig
+@@ -163,6 +163,13 @@ source "drivers/net/ethernet/rdc/Kconfig
  source "drivers/net/ethernet/realtek/Kconfig"
  source "drivers/net/ethernet/renesas/Kconfig"
  source "drivers/net/ethernet/rocker/Kconfig"