tools/mkimage: update to 2023.04
authorNick Hainke <vincent@systemli.org>
Sun, 9 Apr 2023 09:26:20 +0000 (11:26 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 11 Apr 2023 15:30:32 +0000 (17:30 +0200)
Update to latest version.

Signed-off-by: Nick Hainke <vincent@systemli.org>
tools/mkimage/Makefile
tools/mkimage/patches/030-allow-to-use-different-magic.patch

index 022ac219749c023732d21c380216ff2872a6b2df..a6d54f5eff2ae493255b08aec219e48531f4df8b 100644 (file)
@@ -7,14 +7,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mkimage
-PKG_VERSION:=2023.01
+PKG_VERSION:=2023.04
 
 PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
        https://mirror.cyberbits.eu/u-boot \
        https://ftp.denx.de/pub/u-boot \
        ftp://ftp.denx.de/pub/u-boot
-PKG_HASH:=69423bad380f89a0916636e89e6dcbd2e4512d584308d922d1039d1e4331950f
+PKG_HASH:=e31cac91545ff41b71cec5d8c22afd695645cd6e2a442ccdacacd60534069341
 
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
 
index d88f1cf9496ed2bf00ca18b7af208d9c933455eb..c33b0f4327ad71722085f9916c8000b9dcfdb42c 100644 (file)
@@ -33,7 +33,7 @@ This patch makes it possible to set a custom image magic.
  
  static const struct option longopts[] = {
        { "load-address", required_argument, NULL, 'a' },
-@@ -298,6 +300,14 @@ static void process_args(int argc, char
+@@ -302,6 +304,14 @@ static void process_args(int argc, char
                case 'l':
                        params.lflag = 1;
                        break;
@@ -50,7 +50,7 @@ This patch makes it possible to set a custom image magic.
                        break;
 --- a/tools/default_image.c
 +++ b/tools/default_image.c
-@@ -56,7 +56,7 @@ static int image_verify_header(unsigned
+@@ -63,7 +63,7 @@ static int image_verify_header(unsigned
         */
        memcpy(hdr, ptr, sizeof(struct legacy_img_hdr));
  
@@ -59,7 +59,7 @@ This patch makes it possible to set a custom image magic.
                debug("%s: Bad Magic Number: \"%s\" is no valid image\n",
                      params->cmdname, params->imagefile);
                return -FDT_ERR_BADMAGIC;
-@@ -119,7 +119,7 @@ static void image_set_header(void *ptr,
+@@ -142,7 +142,7 @@ static void image_set_header(void *ptr,
        }
  
        /* Build new header */
@@ -70,7 +70,7 @@ This patch makes it possible to set a custom image magic.
        image_set_load(hdr, addr);
 --- a/tools/imagetool.h
 +++ b/tools/imagetool.h
-@@ -59,6 +59,7 @@ struct image_tool_params {
+@@ -67,6 +67,7 @@ struct image_tool_params {
        int arch;
        int type;
        int comp;