ramips: add work-in-progress support for D-Link DIR-X1860
authorFelix Fietkau <nbd@nbd.name>
Tue, 12 Jan 2021 13:20:05 +0000 (14:20 +0100)
committerFelix Fietkau <nbd@nbd.name>
Sat, 11 Dec 2021 12:53:01 +0000 (13:53 +0100)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/boot/uboot-envtools/files/ramips
target/linux/ramips/dts/mt7621_dlink_dir-x1860.dts [new file with mode: 0644]
target/linux/ramips/image/mt7621.mk
target/linux/ramips/mt7621/base-files/etc/board.d/01_leds
target/linux/ramips/mt7621/base-files/etc/board.d/02_network
target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh

index 9ad4d64ed92dbd6d3bbe7b39a47d024684392dc9..3e8d635eeafd2c78884a0515f08678ef10b13dda 100644 (file)
@@ -43,6 +43,9 @@ zbtlink,zbt-wg2626|\
 zte,mf283plus)
        ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x1000" "0x10000"
        ;;
+dlink,dir-x1860)
+       ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x2000" "0x20000"
+       ;;
 hootoo,ht-tm05|\
 ravpower,rp-wd03)
        idx="$(find_mtd_index u-boot-env)"
diff --git a/target/linux/ramips/dts/mt7621_dlink_dir-x1860.dts b/target/linux/ramips/dts/mt7621_dlink_dir-x1860.dts
new file mode 100644 (file)
index 0000000..f481c94
--- /dev/null
@@ -0,0 +1,165 @@
+/dts-v1/;
+
+#include "mt7621.dtsi"
+#include <dt-bindings/input/input.h>
+
+/ {
+       compatible = "dlink,dir-x1860", "mediatek,mt7621-soc";
+       model = "DLink DIR-X1860";
+
+       chosen {
+               bootargs-override = "console=ttyS0,115200";
+       };
+
+       aliases {
+               label-mac-device = &gmac0;
+               led-boot = &led_power_orange;
+               led-failsafe = &led_power_white;
+               led-running = &led_power_white;
+               led-upgrade = &led_net_orange;
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               led_power_white: power_white {
+                       label = "white:power";
+                       gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+               };
+
+               led_net_orange: net_orange {
+                       label = "orange:net";
+                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+               };
+
+               led_power_orange: power_orange {
+                       label = "orange:power";
+                       gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+               };
+
+               led_net_white {
+                       label = "white:net";
+                       gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio 6 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+
+               wps {
+                       label = "wps";
+                       linux,code = <KEY_WPS_BUTTON>;
+                       gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
+&mdio {
+       phy4: ethernet-phy@4 {
+               reg = <4>;
+       };
+};
+
+&gmac1 {
+       status = "okay";
+       phy-handle = <&phy4>;
+};
+
+&switch0 {
+       ports {
+               port@0 {
+                       status = "okay";
+                       label = "lan4";
+               };
+
+               port@1 {
+                       status = "okay";
+                       label = "lan3";
+               };
+
+               port@2 {
+                       status = "okay";
+                       label = "lan2";
+               };
+
+               port@3 {
+                       status = "okay";
+                       label = "lan1";
+               };
+       };
+};
+
+&nand {
+       status = "okay";
+
+       partitions {
+               compatible = "fixed-partitions";
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               partition@0 {
+                       label = "u-boot";
+                       reg = <0x00000 0x80000>;
+                       read-only;
+               };
+
+               partition@80000 {
+                       label = "u-boot-env";
+                       reg = <0x80000 0x80000>;
+               };
+
+               factory: partition@100000 {
+                       label = "factory";
+                       reg = <0x100000 0x80000>;
+               };
+
+               partition@180000 {
+                       label = "kernel";
+                       reg = <0x180000 0x400000>;
+               };
+
+               partition@580000 {
+                       label = "ubi";
+                       reg = <0x580000 0x2b00000>;
+               };
+
+               partition@2c80000 {
+                       label = "firmware2";
+                       reg = <0x2c80000 0x2b00000>;
+               };
+
+               partition@5780000 {
+                       label = "Devdata";
+                       reg = <0x5780000 0x800000>;
+               };
+
+               partition@5f80000 {
+                       label = "User_data";
+                       reg = <0x5f80000 0x2000000>;
+               };
+       };
+};
+
+&state_default {
+       gpio {
+               groups = "i2c", "uart3", "jtag", "wdt";
+               function = "gpio";
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&pcie1 {
+       mt76@0,0 {
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x0000>;
+       };
+};
index 338645df23fe222b43720ae72372942a521bccb4..e14a25748f93975ae5f04bda4403c5f97477a4d8 100644 (file)
@@ -9,6 +9,23 @@ DEFAULT_SOC := mt7621
 KERNEL_DTB += -d21
 DEVICE_VARS += ELECOM_HWNAME LINKSYS_HWNAME
 
+RELOCATE_LOADADDR = 0x81000000
+
+define Build/uImage-relocate
+       mkimage \
+               -A $(LINUX_KARCH) \
+               -O linux \
+               -T kernel \
+               -C $(word 1,$(1)) \
+               -a $(RELOCATE_LOADADDR) \
+               -e $(RELOCATE_LOADADDR) \
+               -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION))' \
+               $(if $(UIMAGE_MAGIC),-M $(UIMAGE_MAGIC)) \
+               $(wordlist 2,$(words $(1)),$(1)) \
+               -d $@ $@.new
+       mv $@.new $@
+endef
+
 define Build/gemtek-trailer
        printf "%s%08X" ".GEMTEK." "$$(cksum $@ | cut -d ' ' -f1)" >> $@
 endef
@@ -393,6 +410,24 @@ define Device/dlink_dir-882-r1
 endef
 TARGET_DEVICES += dlink_dir-882-r1
 
+define Device/dlink_dir-x1860
+  $(Device/dsa-migration)
+  DEVICE_VENDOR := D-Link
+  DEVICE_MODEL := DIR-X1860
+  DEVICE_PACKAGES += kmod-mt7915e uboot-envtools
+  BLOCKSIZE := 128k
+  PAGESIZE := 2048
+  KERNEL_SIZE := 4096k
+  UBINIZE_OPTS := -E 5
+  KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma | uImage-relocate lzma
+  IMAGES += factory.bin
+  IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+  IMAGE/factory.bin := append-kernel | pad-to $$(KERNEL_SIZE) | append-ubi | \
+       check-size
+  IMAGE_SIZE := 40960k
+endef
+TARGET_DEVICES += dlink_dir-x1860
+
 define Device/d-team_newifi-d2
   $(Device/dsa-migration)
   $(Device/uimage-lzma-loader)
index 6e6cd747c40958ee58eb48cb510efeef12e88a74..b02ca1514b6f41f0dec2e0e24a2afe0036aff944 100644 (file)
@@ -47,6 +47,10 @@ dlink,dir-882-a1|\
 dlink,dir-882-r1)
        ucidef_set_led_netdev "wan" "wan" "green:net" "wan"
        ;;
+dlink,dir-x1860)
+       ucidef_set_led_netdev "lan" "LAN Link" "orange:net" "eth0"
+       ucidef_set_led_netdev "wan" "WAN Link" "white:net" "eth1"
+       ;;
 gnubee,gb-pc1|\
 gnubee,gb-pc2)
        ucidef_set_led_netdev "lan1" "lan1" "green:lan1" "lan1"
index a2972ce266d4d473c55c0cd697dd8371f55670b5..bbc6fa88524f869c0faf555c5f4b858c4ba75993 100644 (file)
@@ -44,6 +44,9 @@ ramips_setup_interfaces()
        xiaomi,mi-router-4a-gigabit)
                ucidef_set_interfaces_lan_wan "lan1 lan2" "wan"
                ;;
+       dlink,dir-x1860)
+               ucidef_set_interfaces_lan_wan "lan1 lan2 lan3 lan4" "eth1"
+               ;;
        gnubee,gb-pc1|\
        gnubee,gb-pc2)
                ucidef_set_interface_lan "lan1 lan2"
@@ -114,6 +117,11 @@ ramips_setup_macs()
                lan_mac=$(mtd_get_mac_ascii factory lanmac)
                wan_mac=$(mtd_get_mac_ascii factory wanmac)
                ;;
+       dlink,dir-x1860)
+               lan_mac=$(mtd_get_mac_ascii u-boot-env lanmac)
+               label_mac=$lan_mac
+               wan_mac=$(macaddr_add "$lan_mac" 1)
+               ;;
        edimax,ra21s|\
        edimax,rg21s)
                lan_mac=$(mtd_get_mac_ascii u-boot-env ethaddr)
index 6e8e2054037f7e135c4e7bfe1fc2be02457a05a3..a38208c14206054e24bf498153d5b9fdd7815681 100755 (executable)
@@ -57,6 +57,7 @@ platform_do_upgrade() {
        dlink,dir-2640-a1|\
        dlink,dir-2660-a1|\
        dlink,dir-853-a3|\
+       dlink,dir-x1860|\
        hiwifi,hc5962|\
        jcg,q20|\
        linksys,e5600|\