ipq807x: prpl-haze: fix sysupgrade flashing from bootloader
authorPetr Štetiar <ynezz@true.cz>
Thu, 29 Jun 2023 12:29:02 +0000 (14:29 +0200)
committerPetr Štetiar <ynezz@true.cz>
Fri, 28 Jul 2023 06:19:18 +0000 (08:19 +0200)
While flashing sysupgrade image from U-Boot, then the rootfs_data
overlay filesystem formatting is left for the fstools during firstboot,
but that wont work as mkfs.f2fs is missing in the sysupgrade image:

 mount_root: overlay filesystem in /dev/loop0 has not been formatted yet
 mount_root: no usable overlay filesystem found, using tmpfs overlay
 sh: mkfs.f2fs: not found

 Filesystem                Size      Used Available Use% Mounted on
 /dev/loop0              139.6M     46.9M     92.6M  34% /overlay

 Number  Start (sector)    End (sector)  Size       Code  Name
  20           98850          406349   150.1 MiB   FFFF  rootfs

So lets fix it by adding f2fs support to the sysupgrade image.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
target/linux/qualcommax/image/ipq807x.mk

index 54f8caf5d7a2a2a42a1105aab5c2b2b2f42bf053..555c723c5f423d54373fa086fb297ed805b5e270 100644 (file)
@@ -115,7 +115,8 @@ define Device/prpl_haze
        DEVICE_MODEL := Haze
        DEVICE_DTS_CONFIG := config@hk09
        SOC := ipq8072
-       DEVICE_PACKAGES += ath11k-firmware-qcn9074 ipq-wifi-prpl_haze kmod-ath11k-pci
+       DEVICE_PACKAGES += ath11k-firmware-qcn9074 ipq-wifi-prpl_haze kmod-ath11k-pci \
+               mkf2fs f2fsck kmod-fs-f2fs
 endef
 TARGET_DEVICES += prpl_haze