tools/mkimage: update to 2023.10
authorNick Hainke <vincent@systemli.org>
Sat, 4 Nov 2023 08:57:48 +0000 (09:57 +0100)
committerNick Hainke <vincent@systemli.org>
Thu, 9 Nov 2023 11:50:04 +0000 (12:50 +0100)
Update to latest version.

Remove "100-increase-tmpfile-name-length-limit.patch" because project
is now using limits.h with PATH_MAX [0].

Automatically refreshed:
- 030-allow-to-use-different-magic.patch

[0] - https://github.com/u-boot/u-boot/commit/99d430f344bfdb0641022fd3efa26c29c957df02

Signed-off-by: Nick Hainke <vincent@systemli.org>
tools/mkimage/Makefile
tools/mkimage/patches/030-allow-to-use-different-magic.patch
tools/mkimage/patches/100-increase-tmpfile-name-length-limit.patch [deleted file]

index a6d54f5eff2ae493255b08aec219e48531f4df8b..5dceb9a471778af219e58f3bc92459f0db704b18 100644 (file)
@@ -7,14 +7,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mkimage
-PKG_VERSION:=2023.04
+PKG_VERSION:=2023.10
 
 PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
        https://mirror.cyberbits.eu/u-boot \
        https://ftp.denx.de/pub/u-boot \
        ftp://ftp.denx.de/pub/u-boot
-PKG_HASH:=e31cac91545ff41b71cec5d8c22afd695645cd6e2a442ccdacacd60534069341
+PKG_HASH:=e00e6c6f014e046101739d08d06f328811cebcf5ae101348f409cbbd55ce6900
 
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
 
index c33b0f4327ad71722085f9916c8000b9dcfdb42c..3689fcb531538df147e1b182e6cd4f11eabe0880 100644 (file)
@@ -50,7 +50,7 @@ This patch makes it possible to set a custom image magic.
                        break;
 --- a/tools/default_image.c
 +++ b/tools/default_image.c
-@@ -63,7 +63,7 @@ static int image_verify_header(unsigned
+@@ -68,7 +68,7 @@ static int image_verify_header(unsigned
         */
        memcpy(hdr, ptr, sizeof(struct legacy_img_hdr));
  
@@ -59,7 +59,7 @@ This patch makes it possible to set a custom image magic.
                debug("%s: Bad Magic Number: \"%s\" is no valid image\n",
                      params->cmdname, params->imagefile);
                return -FDT_ERR_BADMAGIC;
-@@ -142,7 +142,7 @@ static void image_set_header(void *ptr,
+@@ -147,7 +147,7 @@ static void image_set_header(void *ptr,
        }
  
        /* Build new header */
diff --git a/tools/mkimage/patches/100-increase-tmpfile-name-length-limit.patch b/tools/mkimage/patches/100-increase-tmpfile-name-length-limit.patch
deleted file mode 100644 (file)
index aae8935..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/tools/mkimage.h
-+++ b/tools/mkimage.h
-@@ -44,7 +44,7 @@ static inline ulong map_to_sysmem(void *
- #define ALLOC_CACHE_ALIGN_BUFFER(type, name, size) type name[size]
- #define MKIMAGE_TMPFILE_SUFFIX                ".tmp"
--#define MKIMAGE_MAX_TMPFILE_LEN               256
-+#define MKIMAGE_MAX_TMPFILE_LEN               1024
- #define MKIMAGE_DEFAULT_DTC_OPTIONS   "-I dts -O dtb -p 500"
- #define MKIMAGE_MAX_DTC_CMDLINE_LEN   2 * MKIMAGE_MAX_TMPFILE_LEN + 35