tools/libtool: bootstrap to local gnulib source
authorMichael Pratt <mcpratt@pm.me>
Thu, 23 Mar 2023 07:53:52 +0000 (03:53 -0400)
committerChristian Marangi <ansuelsmth@gmail.com>
Thu, 4 May 2023 04:07:30 +0000 (06:07 +0200)
Using the local gnulib source during bootstrap
allows for fine-grained control over the macros
and source files for use with libtool
but part of gnulib instead of libtool,
without having to wait for a release
or deal with gnulib as a git submodule.

Signed-off-by: Michael Pratt <mcpratt@pm.me>
tools/Makefile
tools/libtool/Makefile

index 3bf94827cf6bbad7f807af9c24e6f7d0dc35bcd1..3f12828a8f3e4b1be7c6ba6bef05eff324366626 100644 (file)
@@ -104,7 +104,7 @@ $(curdir)/gmp/compile := $(curdir)/libtool/compile
 $(curdir)/isl/compile := $(curdir)/gmp/compile
 $(curdir)/liblzo/compile := $(curdir)/cmake/compile
 $(curdir)/libressl/compile := $(curdir)/pkgconf/compile
-$(curdir)/libtool/compile := $(curdir)/automake/compile $(curdir)/missing-macros/compile
+$(curdir)/libtool/compile := $(curdir)/automake/compile $(curdir)/gnulib/compile $(curdir)/missing-macros/compile
 $(curdir)/lz4/compile := $(curdir)/meson/compile
 $(curdir)/lzma-old/compile := $(curdir)/zlib/compile
 $(curdir)/lzop/compile := $(curdir)/cmake/compile $(curdir)/liblzo/compile
index b4f3ecc36ba347a75b50934eb2ddf27b0c5039c1..118719147821b9c163ece69e63ea6a6026fba015 100644 (file)
@@ -18,17 +18,31 @@ HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
+export GNULIB_SRCDIR:=$(HOST_GNULIB_SRCDIR)
+
 HOST_CONFIGURE_VARS += \
        lt_cv_sys_dlsearch_path=""
 
+define Host/Bootstrap
+       ( \
+               cd $(HOST_BUILD_DIR); \
+               $(AM_TOOL_PATHS) \
+               ./bootstrap \
+                       --force \
+                       --skip-git \
+                       --skip-po \
+                       --gnulib-srcdir=$(GNULIB_SRCDIR) \
+       )
+endef
+
 define Host/Prepare
        $(call Host/Prepare/Default)
        $(call Host/Uninstall)
-       $(if $(QUILT),,(cd $(HOST_BUILD_DIR); touch README-release; $(AM_TOOL_PATHS) ./bootstrap --skip-git --skip-po --force))
+       $(if $(QUILT),,$(call Host/Bootstrap))
 endef
 
 define Host/Configure
-       $(if $(QUILT),(cd $(HOST_BUILD_DIR); touch README-release; $(AM_TOOL_PATHS) ./bootstrap --skip-git --skip-po --force))
+       $(if $(QUILT),$(call Host/Bootstrap))
        $(call Host/Configure/Default)
 endef