tools/elfutils: override SUBDIRS variable of Makefile
authorMichael Pratt <mcpratt@pm.me>
Sun, 7 Apr 2024 19:28:03 +0000 (15:28 -0400)
committerRobert Marko <robimarko@gmail.com>
Thu, 25 Apr 2024 19:33:51 +0000 (21:33 +0200)
Instead of editing the SUBDIRS variable with a patch, it can be overriden
at the end of the command line when invoking Make.

This tool has a series of recursive Makefiles in each subdirectory,
therefore SUBDIRS is set to a pattern of Make functions so that the result
is variable depending on the current subdirectory that Make is being
invoked in.

It's not necessary to have gnulib-cache.m4 in EXTRA_DIST since we don't
need to re-import after packaging this in the SDK, so get rid of the
entire patch hunk for ./Makefile.am

Tested-by: Georgi Valkov <gvalkov@gmail.com> # MacOS
Signed-off-by: Michael Pratt <mcpratt@pm.me>
Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
tools/elfutils/Makefile
tools/elfutils/patches/100-portability.patch

index adf8770783e257cb46899fc5decec9eb81afd182..f13bd8c944b84e11c9d1a1a7a826f92db4046924 100644 (file)
@@ -17,6 +17,18 @@ PKG_CPE_ID:=cpe:/a:elfutils_project:elfutils
 PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 
+PKG_SUBDIRS := \
+       libgnu \
+       config \
+       lib \
+       libelf \
+       libcpu \
+       backends \
+       libebl \
+       libdwelf \
+       libdwfl \
+       libdw
+
 include $(INCLUDE_DIR)/host-build.mk
 
 ifeq ($(HOST_OS),Darwin)
@@ -47,6 +59,14 @@ define Host/Gnulib
        ln -sf ../lib/eu-config.h $(HOST_BUILD_DIR)/libgnu/;
 endef
 
+define Host/Compile
+       $(call Host/Compile/Default,SUBDIRS='$$$$(wildcard $(PKG_SUBDIRS))')
+endef
+
+define Host/Install
+       $(call Host/Compile/Default,install SUBDIRS='$$$$(wildcard $(PKG_SUBDIRS))')
+endef
+
 define Host/Uninstall
        -$(call Host/Compile/Default,uninstall)
 endef
index 0a3dd63a85f162a570f2ab3a90290049abe1ebd9..91fff1ca7871edb017be9c6de9ada7f0298c11ae 100644 (file)
  dnl The directories with content.
  
  dnl Documentation.
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -26,11 +26,11 @@ AM_MAKEFLAGS = --no-print-directory
- pkginclude_HEADERS = version.h
--SUBDIRS = config lib libelf libcpu backends libebl libdwelf libdwfl libdw \
--        libasm debuginfod src po doc tests
-+SUBDIRS = libgnu config lib libelf libcpu backends libebl libdwelf libdwfl libdw
- EXTRA_DIST = elfutils.spec GPG-KEY NOTES CONTRIBUTING SECURITY \
--           COPYING COPYING-GPLV2 COPYING-LGPLV3
-+           COPYING COPYING-GPLV2 COPYING-LGPLV3 \
-+               m4/gnulib-cache.m4
- # Make sure the test install uses lib64 when $LIB will yield lib64.
- # Make sure the test build uses the same compiler, which on e.g. ppc64
 --- a/libelf/elf_update.c
 +++ b/libelf/elf_update.c
 @@ -37,6 +37,33 @@