ath79: add WWAN serial driver for GL.iNET GL-XE300
authorDavid Bauer <mail@david-bauer.net>
Mon, 9 Oct 2023 10:47:38 +0000 (12:47 +0200)
committerDavid Bauer <mail@david-bauer.net>
Mon, 9 Oct 2023 10:47:41 +0000 (12:47 +0200)
The driver for the cellular modems serial interface was missing from the
default device packages.

The driver is required to interact with the modem using AT commands.
Other devices with a 4G modem also ship with this package, thus let's
add it to the default packages for the board.

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/ath79/image/nand.mk

index e4ee5554512caeb160c8096c3c55bad145b5e62b..fd3245070239b1d3663c63aaec05075fe148f721 100644 (file)
@@ -208,7 +208,7 @@ define Device/glinet_gl-xe300
   DEVICE_VENDOR := GL.iNet
   DEVICE_MODEL := GL-XE300
   DEVICE_PACKAGES := kmod-usb2 block-mount kmod-usb-serial-ch341 \
-       kmod-usb-net-qmi-wwan uqmi
+       kmod-usb-serial-option kmod-usb-net-qmi-wwan uqmi
   KERNEL_SIZE := 4096k
   IMAGE_SIZE := 131072k
   PAGESIZE := 2048