kernel/ksmbd: fix build for 5.15.145
authorJohn Audia <therealgraysky@proton.me>
Wed, 27 Dec 2023 09:42:41 +0000 (04:42 -0500)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 4 Jan 2024 21:25:17 +0000 (22:25 +0100)
Include a patch[1] under review to fix the modpost error due to
upstream changes:
...
ERROR: modpost: "cifs_arc4_crypt" [fs/ksmbd/ksmbd.ko] undefined!
ERROR: modpost: "cifs_arc4_setkey" [fs/ksmbd/ksmbd.ko] undefined!
scripts/Makefile.modpost:133: recipe for target 'modules-only.symvers' failed

1. https://lore.kernel.org/all/20231227102605.4766-2-linkinjeon@kernel.org/

Signed-off-by: John Audia <therealgraysky@proton.me>
target/linux/generic/hack-5.15/940-ksmbd-have-a-dependency-on-cifs-arc4.patch [new file with mode: 0644]

diff --git a/target/linux/generic/hack-5.15/940-ksmbd-have-a-dependency-on-cifs-arc4.patch b/target/linux/generic/hack-5.15/940-ksmbd-have-a-dependency-on-cifs-arc4.patch
new file mode 100644 (file)
index 0000000..4cf420a
--- /dev/null
@@ -0,0 +1,31 @@
+From: Namjae Jeon <linkinjeon@kernel.org>
+To: sashal@kernel.org, gregkh@linuxfoundation.org, stable@vger.kernel.org
+Cc: smfrench@gmail.com, Namjae Jeon <linkinjeon@kernel.org>
+Subject: [PATCH v2 5.15.y 1/8] ksmbd: have a dependency on cifs ARC4
+Date: Wed, 27 Dec 2023 19:25:58 +0900  [thread overview]
+Message-ID: <20231227102605.4766-2-linkinjeon@kernel.org> (raw)
+In-Reply-To: <20231227102605.4766-1-linkinjeon@kernel.org>
+
+Omitted the change that has a dependency on cifs ARC4 from backporting
+commit f9929ef6a2a5("ksmbd: add support for key exchange").
+This patch make ksmbd have a dependeny on cifs ARC4.
+
+Fixes: c5049d2d73b2 ("ksmbd: add support for key exchange")
+Signed-off-by: Namjae Jeon <linkinjeon@kernel.org>
+---
+ fs/Kconfig | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+--- a/fs/Kconfig
++++ b/fs/Kconfig
+@@ -369,8 +369,8 @@ source "fs/ksmbd/Kconfig"
+ config SMBFS_COMMON
+       tristate
+-      default y if CIFS=y
+-      default m if CIFS=m
++      default y if CIFS=y || SMB_SERVER=y
++      default m if CIFS=m || SMB_SERVER=m
+ source "fs/coda/Kconfig"
+ source "fs/afs/Kconfig"