tools/cpio: update to 2.14
authorLinhui Liu <liulinhui36@gmail.com>
Sun, 7 May 2023 07:28:32 +0000 (15:28 +0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 9 May 2023 09:38:18 +0000 (11:38 +0200)
Noteworthy changes in this release:

* New option --ignore-dirnlink

Valid in copy-out mode, it instructs cpio to ignore the actual number
of links reported for each directory member and always store 2
instead.

* Changes in --reproducible option

The --reproducible option implies --ignore-dirlink.  In other words,
it is equivalent to --ignore-devno --ignore-dirnlink --renumber-inodes.

* Use GNU ls algorithm for deciding timestamp format in -tv mode

* Bugfixes

** Fix cpio header verification.

** Fix handling of device numbers on copy out.

** Fix calculation of CRC in copy-out mode.

** Rewrite the fix for CVE-2015-1197.

** Fix combination of --create --append --directory.

** Fix appending to archives bigger than 2G.

Removed upstreamed:
- 001-duplicate-program-name.patch
- 010-clang.patch

Signed-off-by: Linhui Liu <liulinhui36@gmail.com>
tools/cpio/Makefile
tools/cpio/patches/001-duplicate-program-name.patch [deleted file]
tools/cpio/patches/010-clang.patch [deleted file]

index 82b5aa83652913a31be35ea94c32e96389b2ad66..1550785ddc5d71be6c9bf5dd07c5a2ff3f2af6ed 100644 (file)
@@ -3,11 +3,11 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cpio
 PKG_CPE_ID:=cpe:/a:gnu:cpio
-PKG_VERSION:=2.13
+PKG_VERSION:=2.14
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@GNU/cpio
-PKG_HASH:=eab5bdc5ae1df285c59f2a4f140a98fc33678a0bf61bdba67d9436ae26b46f6d
+PKG_HASH:=fcdc15d60f7267a6fc7efcd6b9db7b6c8966c4f2fbbb964c24d41336fd3f2c12
 
 include $(INCLUDE_DIR)/host-build.mk
 
diff --git a/tools/cpio/patches/001-duplicate-program-name.patch b/tools/cpio/patches/001-duplicate-program-name.patch
deleted file mode 100644 (file)
index a7c3fbc..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-author Sergey Poznyakoff <gray@gnu.org>
-
-https://git.savannah.gnu.org/cgit/cpio.git/commit/?id=641d3f489cf6238bb916368d4ba0d9325a235afb
-
-* src/global.c: Remove superfluous declaration of program_name
-
---- a/src/global.c
-+++ b/src/global.c
-@@ -184,9 +184,6 @@ unsigned int warn_option = 0;
- /* Extract to standard output? */
- bool to_stdout_option = false;
--/* The name this program was run with.  */
--char *program_name;
--
- /* A pointer to either lstat or stat, depending on whether
-    dereferencing of symlinks is done for input files.  */
- int (*xstat) ();
diff --git a/tools/cpio/patches/010-clang.patch b/tools/cpio/patches/010-clang.patch
deleted file mode 100644 (file)
index 89c7a81..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/gnu/xalloc-oversized.h
-+++ b/gnu/xalloc-oversized.h
-@@ -52,7 +52,7 @@ typedef size_t __xalloc_count_type;
- #elif ((5 <= __GNUC__ \
-         || (__has_builtin (__builtin_mul_overflow) \
-             && __has_builtin (__builtin_constant_p))) \
--       && !__STRICT_ANSI__)
-+       && !__STRICT_ANSI__) && !defined(__clang__)
- # define xalloc_oversized(n, s) \
-    (__builtin_constant_p (n) && __builtin_constant_p (s) \
-     ? __xalloc_oversized (n, s) \