sunxi: move KERNEL_LOADADDR into subtargets
authorZoltan HERPAI <wigyori@uid0.hu>
Sat, 23 Mar 2024 22:58:36 +0000 (23:58 +0100)
committerZoltan HERPAI <wigyori@uid0.hu>
Fri, 19 Apr 2024 16:42:05 +0000 (18:42 +0200)
As preparation for the arm926ej-s support which has a different
load address, move the KERNEL_LOADADDR into the subtargets.

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
target/linux/sunxi/image/Makefile
target/linux/sunxi/image/cortexa53.mk
target/linux/sunxi/image/cortexa7.mk
target/linux/sunxi/image/cortexa8.mk

index 738585accc86cc7983b9c0fd56f56989ec2780a8..cc1c1ba42de3fe63173dd2721700d8465b3e6ded 100644 (file)
@@ -10,7 +10,6 @@ FAT32_BLOCK_SIZE=1024
 FAT32_BLOCKS=$(shell echo $$(($(CONFIG_SUNXI_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
 
 DEVICE_VARS := SUNXI_DTS SUNXI_DTS_DIR
-KERNEL_LOADADDR:=0x40008000
 
 define Build/sunxi-sdcard
        rm -f $@.boot
index 63ada59f85fafffe7c43f485dba3b6756c7f3b7d..06b409deb72b3290c7778bbdea8f04768ffbde56 100644 (file)
@@ -3,6 +3,8 @@
 # Copyright (C) 2013-2016 OpenWrt.org
 # Copyright (C) 2016 Yousong Zhou
 
+KERNEL_LOADADDR:=0x40008000
+
 define Device/sun50i
   SUNXI_DTS_DIR := allwinner/
   KERNEL_NAME := Image
index 3191cec4fd8ff298047902256ef7d5c7b4bbc896..a85b20531d3af1cf8083914a78850af128cbc8c3 100644 (file)
@@ -3,6 +3,8 @@
 # Copyright (C) 2013-2019 OpenWrt.org
 # Copyright (C) 2016 Yousong Zhou
 
+KERNEL_LOADADDR:=0x40008000
+
 define Device/cubietech_cubieboard2
   DEVICE_VENDOR := Cubietech
   DEVICE_MODEL := Cubieboard2
index dd8a16763b0bb9fbdeaeac37c9d91d7930466475..e27db1ee16a1752c149ceb1f46486597c2e18760 100644 (file)
@@ -3,6 +3,8 @@
 # Copyright (C) 2013-2016 OpenWrt.org
 # Copyright (C) 2016 Yousong Zhou
 
+KERNEL_LOADADDR:=0x40008000
+
 define Device/cubietech_a10-cubieboard
   DEVICE_VENDOR := Cubietech
   DEVICE_MODEL := Cubieboard