build: do not depend on $(STAGING_DIR)/.prepared when in SDK
authorMatthias Schiffer <mschiffer@universe-factory.net>
Mon, 4 Mar 2024 22:45:15 +0000 (23:45 +0100)
committerMatthias Schiffer <mschiffer@universe-factory.net>
Mon, 4 Mar 2024 22:45:15 +0000 (23:45 +0100)
The dependency can't be satisfied when building using the SDK, breaking
package builds. As the staging and bin dirs are distributed with the SDK
archive, ignoring the dependency is fine when SDK is set.

Fixes: fbb924abff8a ("build: add $(STAGING_DIR) and $(BIN_DIR) ...")
Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
package/Makefile

index 4663b41de4aea0930fa48287f685537e6027bca7..d72ce09a816b42ad879c507c1e9517db3dbe33de 100644 (file)
@@ -59,6 +59,7 @@ $(curdir)/merge-index: $(curdir)/merge
        (cd $(PACKAGE_DIR_ALL) && $(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages; )
 
 ifndef SDK
+  $(curdir)//compile = $(STAGING_DIR)/.prepared $(BIN_DIR)
   $(curdir)/compile: $(curdir)/system/opkg/host/compile
 endif
 
@@ -117,8 +118,6 @@ endif
 
 $(curdir)/flags-install:= -j1
 
-$(curdir)//compile = $(STAGING_DIR)/.prepared $(BIN_DIR)
-
 $(eval $(call stampfile,$(curdir),package,prereq,.config))
 $(eval $(call stampfile,$(curdir),package,cleanup,$(TMP_DIR)/.build))
 $(eval $(call stampfile,$(curdir),package,compile,$(TMP_DIR)/.build))