generic: routerboot partition build bits
authorThibaut VARÈNE <hacks@slashdirt.org>
Tue, 24 Mar 2020 10:19:41 +0000 (11:19 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 8 May 2020 13:17:17 +0000 (15:17 +0200)
Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org>
target/linux/generic/config-4.14
target/linux/generic/config-4.19
target/linux/generic/config-5.4
target/linux/generic/pending-4.14/435-mtd-add-routerbootpart-parser-config.patch [new file with mode: 0644]
target/linux/generic/pending-4.19/435-mtd-add-routerbootpart-parser-config.patch [new file with mode: 0644]
target/linux/generic/pending-5.4/435-mtd-add-routerbootpart-parser-config.patch [new file with mode: 0644]

index cd087227ae6788279e769f9f12bd1f07ad538a54..c8b3c602dd2db1563bddd8d61aa03460cf436e69 100644 (file)
@@ -2877,6 +2877,7 @@ CONFIG_MTD_REDBOOT_DIRECTORY_BLOCK=-1
 # CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED is not set
 # CONFIG_MTD_ROM is not set
 CONFIG_MTD_ROOTFS_ROOT_DEV=y
+# CONFIG_MTD_ROUTERBOOT_PARTS is not set
 # CONFIG_MTD_SLRAM is not set
 # CONFIG_MTD_SM_COMMON is not set
 # CONFIG_MTD_SPINAND_MT29F is not set
index 4ce3de57ad2d972e66e742f493c39759b52ae149..9e3e35f793703d692aaf56fc6aa8a4a093e68a41 100644 (file)
@@ -3024,6 +3024,7 @@ CONFIG_MTD_REDBOOT_DIRECTORY_BLOCK=-1
 # CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED is not set
 # CONFIG_MTD_ROM is not set
 CONFIG_MTD_ROOTFS_ROOT_DEV=y
+# CONFIG_MTD_ROUTERBOOT_PARTS is not set
 # CONFIG_MTD_SLRAM is not set
 # CONFIG_MTD_SM_COMMON is not set
 # CONFIG_MTD_SPINAND_MT29F is not set
index fc9b9664da520797635ebcdb890f76df79126cf8..67a69ef741e93fe846e6d64bfcfe241941d5cca1 100644 (file)
@@ -3221,6 +3221,7 @@ CONFIG_MTD_REDBOOT_DIRECTORY_BLOCK=-1
 # CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED is not set
 # CONFIG_MTD_ROM is not set
 CONFIG_MTD_ROOTFS_ROOT_DEV=y
+# CONFIG_MTD_ROUTERBOOT_PARTS is not set
 # CONFIG_MTD_SLRAM is not set
 # CONFIG_MTD_SM_COMMON is not set
 # CONFIG_MTD_SPINAND_MT29F is not set
diff --git a/target/linux/generic/pending-4.14/435-mtd-add-routerbootpart-parser-config.patch b/target/linux/generic/pending-4.14/435-mtd-add-routerbootpart-parser-config.patch
new file mode 100644 (file)
index 0000000..192886b
--- /dev/null
@@ -0,0 +1,43 @@
+From 4437e01fb6bca63fccdba5d6c44888b0935885c2 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Thibaut=20VAR=C3=88NE?= <hacks@slashdirt.org>
+Date: Tue, 24 Mar 2020 11:45:07 +0100
+Subject: [PATCH] generic: routerboot partition build bits (4.14)
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+This patch adds routerbootpart kernel build bits
+
+Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org>
+---
+ drivers/mtd/parsers/Kconfig  | 9 +++++++++
+ drivers/mtd/parsers/Makefile | 1 +
+ 2 files changed, 10 insertions(+)
+
+diff --git a/drivers/mtd/parsers/Kconfig b/drivers/mtd/parsers/Kconfig
+index d206b3c..58cbdd6 100644
+--- a/drivers/mtd/parsers/Kconfig
++++ b/drivers/mtd/parsers/Kconfig
+@@ -6,3 +6,12 @@ config MTD_PARSER_TRX
+         may contain up to 3/4 partitions (depending on the version).
+         This driver will parse TRX header and report at least two partitions:
+         kernel and rootfs.
++
++config MTD_ROUTERBOOT_PARTS
++      tristate "RouterBoot flash partition parser"
++      depends on MTD && OF
++      help
++        MikroTik RouterBoot is implemented as a multi segment system on the
++        flash, some of which are fixed and some of which are located at
++        variable offsets. This parser handles both cases via properly
++        formatted DTS.
+diff --git a/drivers/mtd/parsers/Makefile b/drivers/mtd/parsers/Makefile
+index 4d9024e..41d363a 100644
+--- a/drivers/mtd/parsers/Makefile
++++ b/drivers/mtd/parsers/Makefile
+@@ -1 +1,2 @@
+ obj-$(CONFIG_MTD_PARSER_TRX)          += parser_trx.o
++obj-$(CONFIG_MTD_ROUTERBOOT_PARTS)    += routerbootpart.o
+-- 
+2.11.0
+
diff --git a/target/linux/generic/pending-4.19/435-mtd-add-routerbootpart-parser-config.patch b/target/linux/generic/pending-4.19/435-mtd-add-routerbootpart-parser-config.patch
new file mode 100644 (file)
index 0000000..678eaed
--- /dev/null
@@ -0,0 +1,41 @@
+From 4437e01fb6bca63fccdba5d6c44888b0935885c2 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Thibaut=20VAR=C3=88NE?= <hacks@slashdirt.org>
+Date: Tue, 24 Mar 2020 11:45:07 +0100
+Subject: [PATCH] generic: routerboot partition build bits (4.19)
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+This patch adds routerbootpart kernel build bits
+
+Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org>
+---
+ drivers/mtd/parsers/Kconfig  | 9 +++++++++
+ drivers/mtd/parsers/Makefile | 1 +
+ 2 files changed, 10 insertions(+)
+
+diff --git a/drivers/mtd/parsers/Kconfig b/drivers/mtd/parsers/Kconfig
+index de6f5f8..0afa89c 100644
+--- a/drivers/mtd/parsers/Kconfig
++++ b/drivers/mtd/parsers/Kconfig
+@@ -22,3 +22,12 @@ config MTD_SHARPSL_PARTS
+         This provides the read-only FTL logic necessary to read the partition
+         table from the NAND flash of Sharp SL Series (Zaurus) and the MTD
+         partition parser using this code.
++
++config MTD_ROUTERBOOT_PARTS
++      tristate "RouterBoot flash partition parser"
++      depends on MTD && OF
++      help
++        MikroTik RouterBoot is implemented as a multi segment system on the
++        flash, some of which are fixed and some of which are located at
++        variable offsets. This parser handles both cases via properly
++        formatted DTS.
+diff --git a/drivers/mtd/parsers/Makefile b/drivers/mtd/parsers/Makefile
+index 44ff342..0543362 100644
+--- a/drivers/mtd/parsers/Makefile
++++ b/drivers/mtd/parsers/Makefile
+@@ -1,2 +1,3 @@
+ obj-$(CONFIG_MTD_PARSER_TRX)          += parser_trx.o
+ obj-$(CONFIG_MTD_SHARPSL_PARTS)               += sharpslpart.o
++obj-$(CONFIG_MTD_ROUTERBOOT_PARTS)            += routerbootpart.o
diff --git a/target/linux/generic/pending-5.4/435-mtd-add-routerbootpart-parser-config.patch b/target/linux/generic/pending-5.4/435-mtd-add-routerbootpart-parser-config.patch
new file mode 100644 (file)
index 0000000..3ab7883
--- /dev/null
@@ -0,0 +1,38 @@
+From 4437e01fb6bca63fccdba5d6c44888b0935885c2 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Thibaut=20VAR=C3=88NE?= <hacks@slashdirt.org>
+Date: Tue, 24 Mar 2020 11:45:07 +0100
+Subject: [PATCH] generic: routerboot partition build bits (5.4)
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+This patch adds routerbootpart kernel build bits
+
+Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org>
+---
+ drivers/mtd/parsers/Kconfig  | 9 +++++++++
+ drivers/mtd/parsers/Makefile | 1 +
+ 2 files changed, 10 insertions(+)
+
+--- a/drivers/mtd/parsers/Kconfig
++++ b/drivers/mtd/parsers/Kconfig
+@@ -160,3 +160,12 @@ config MTD_REDBOOT_PARTS_READONLY
+         'FIS directory' images, enable this option.
+ endif # MTD_REDBOOT_PARTS
++
++config MTD_ROUTERBOOT_PARTS
++      tristate "RouterBoot flash partition parser"
++      depends on MTD && OF
++      help
++        MikroTik RouterBoot is implemented as a multi segment system on the
++        flash, some of which are fixed and some of which are located at
++        variable offsets. This parser handles both cases via properly
++        formatted DTS.
+--- a/drivers/mtd/parsers/Makefile
++++ b/drivers/mtd/parsers/Makefile
+@@ -10,3 +10,4 @@
+ obj-$(CONFIG_MTD_SHARPSL_PARTS)               += sharpslpart.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS)               += redboot.o
+ obj-$(CONFIG_MTD_MYLOADER_PARTS)      += myloader.o
++obj-$(CONFIG_MTD_ROUTERBOOT_PARTS)    += routerbootpart.o