tools/lz4: build with meson
authorRosen Penev <rosenp@gmail.com>
Thu, 20 Apr 2023 08:59:32 +0000 (01:59 -0700)
committerChristian Marangi <ansuelsmth@gmail.com>
Thu, 20 Apr 2023 12:21:46 +0000 (14:21 +0200)
Simplifies Makefile and speeds up compilation.

Before:
Executed in   68.00 secs    fish           external
   usr time  104.17 secs    1.33 millis  104.17 secs
   sys time    4.29 secs    0.35 millis    4.29 secs

After:
Executed in   27.98 secs    fish           external
   usr time   25.18 secs    1.32 millis   25.18 secs
   sys time    3.31 secs    0.35 millis    3.31 secs

Signed-off-by: Rosen Penev <rosenp@gmail.com>
tools/Makefile
tools/lz4/Makefile

index 722d42b2c27bda7ac6294aacbeafc74a64385a58..7e8fbad107e6b47f0a0fe28144771da4c029d51a 100644 (file)
@@ -104,6 +104,7 @@ $(curdir)/isl/compile := $(curdir)/gmp/compile
 $(curdir)/liblzo/compile := $(curdir)/cmake/compile
 $(curdir)/libressl/compile := $(curdir)/pkgconf/compile
 $(curdir)/libtool/compile := $(curdir)/automake/compile $(curdir)/missing-macros/compile
+$(curdir)/lz4/compile := $(curdir)/meson/compile
 $(curdir)/lzma-old/compile := $(curdir)/zlib/compile
 $(curdir)/lzop/compile := $(curdir)/cmake/compile $(curdir)/liblzo/compile
 $(curdir)/llvm-bpf/compile := $(curdir)/cmake/compile
index c5d4f6f16b26e1899d8e7bfd8ce40f4b98ac3618..8f12ca93e68329d871a1ae889d535efa5ec1beee 100644 (file)
@@ -17,33 +17,21 @@ PKG_HASH:=0b0e3aa07c8c063ddf40b082bdf7e37a1562bda40a0ff5272957f3e987e0e54b
 PKG_LICENSE:=BSD-2-Clause
 PKG_LICENSE_FILES:=LICENSE lib/LICENSE
 
-HOST_BUILD_PARALLEL:=1
-
 include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/meson.mk
+
+MESON_HOST_BUILD_DIR:=$(HOST_BUILD_DIR)/contrib/meson/openwrt-build
 
 # Always optimize for speed
 HOST_CFLAGS := $(filter-out -O%,$(HOST_CFLAGS)) -O3
 
-HOST_MAKE_FLAGS+=PREFIX=$(HOST_BUILD_PREFIX) \
-                ENABLE_DOCS=1
-
-define Host/Configure
-endef
-
-define Host/Compile
-       $(call Host/Compile/Default,default)
-endef
-
-define Host/Install
-       $(call Host/Compile/Default,install)
-endef
-
-define Host/Uninstall
-       $(call Host/Compile/Default,uninstall)
-       $(call Host/Compile/Default,clean)
-endef
-
-define Host/Clean
-endef
+MESON_HOST_ARGS += \
+       -Ddefault_library=static \
+       -Ddebug-level=0 \
+       -Dunstable=false \
+       -Dprograms=true \
+       -Dtests=false \
+       -Dcontrib=false \
+       -Dexamples=false
 
 $(eval $(call HostBuild))