kernel: modules: video: package DRM suballocation helper
authorRobert Marko <robimarko@gmail.com>
Fri, 15 Mar 2024 11:50:14 +0000 (12:50 +0100)
committerRobert Marko <robimarko@gmail.com>
Fri, 15 Mar 2024 14:25:03 +0000 (15:25 +0100)
Linux 6.4 has split out the previously AMDGPU specific suballocation
helper into a generic one and it has its own symbol now.

So, lets package it as a separate helper as AMDGPU still requires it
for 6.6.

Signed-off-by: Robert Marko <robimarko@gmail.com>
package/kernel/linux/modules/video.mk

index 73c94e391c38ef8c1695d8ef745ba6a4233aa023..1e12ffbb4081bda2d60a31cc5601a7bbeeca6d0b 100644 (file)
@@ -353,6 +353,22 @@ endef
 
 $(eval $(call KernelPackage,drm-kms-helper))
 
+define KernelPackage/drm-suballoc-helper
+  SUBMENU:=$(VIDEO_MENU)
+  HIDDEN:=1
+  TITLE:=DRM suballocation helper
+  DEPENDS:=@DISPLAY_SUPPORT +kmod-drm @LINUX_6_6
+  KCONFIG:=CONFIG_DRM_SUBALLOC_HELPER
+  FILES:=$(LINUX_DIR)/drivers/gpu/drm/drm_suballoc_helper.ko
+  AUTOLOAD:=$(call AutoProbe,drm_suballoc_helper)
+endef
+
+define KernelPackage/drm-suballoc-helper/description
+  DRM suballocation helper.
+endef
+
+$(eval $(call KernelPackage,drm-suballoc-helper))
+
 define KernelPackage/drm-amdgpu
   SUBMENU:=$(VIDEO_MENU)
   TITLE:=AMDGPU DRM support