at91: Automatically detect USB feature
authorHauke Mehrtens <hauke@hauke-m.de>
Wed, 6 Apr 2022 22:36:25 +0000 (00:36 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 7 Apr 2022 19:01:48 +0000 (21:01 +0200)
The sama7 sub target does not have USB support, the feature should not
be activated there. OpenWrt can automatically detect if the target
supports USB by using the scripts/target-metadata.pl script. With the
automatic detection USB support will only get activated on subtargest
which actually support USB like sam9x and sama5.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/at91/Makefile

index 36804a1eeb6f3e6337cc1dfef141c88fcae6a4e4..af0dc3f338494d45ce2464fb243c441a5390dd86 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=at91
 BOARDNAME:=Microchip (Atmel AT91)
-FEATURES:=ext4 squashfs targz usb usbgadget ubifs
+FEATURES:=ext4 squashfs targz usbgadget ubifs
 SUBTARGETS:=sama7 sama5 sam9x
 
 KERNEL_PATCHVER:=5.10