ipq40xx: reenable Zyxel NBG6617 by default
authorChristian Lamparter <chunkeey@gmail.com>
Fri, 5 Nov 2021 23:42:43 +0000 (00:42 +0100)
committerChristian Lamparter <chunkeey@gmail.com>
Sun, 14 Nov 2021 13:29:47 +0000 (14:29 +0100)
The Zyxel NBG6617 already uses lzma to compress the kernel.
A local build with every module enabled (either as =Y or =M)
ended produced a 3058 KiB kernel (the kernel partition is 4MiB).
It booted just fine, let's reenable the device.

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
target/linux/ipq40xx/image/generic.mk

index 6956679e37735ad987a8f31d3be5a5d211593dd2..c24eb285234558cf1d6cd1023fae30371078ef77 100644 (file)
@@ -906,7 +906,6 @@ define Device/zyxel_nbg6617
        IMAGE/factory.bin := append-rootfs | pad-rootfs | pad-to 64k | check-size $$$$(ROOTFS_SIZE) | zyxel-ras-image separate-kernel
        IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | check-size $$$$(ROOTFS_SIZE) | sysupgrade-tar rootfs=$$$$@ | append-metadata
        DEVICE_PACKAGES := kmod-usb-ledtrig-usbport
-       DEFAULT := n
 endef
 TARGET_DEVICES += zyxel_nbg6617