kernel: bump 5.4 to 5.4.159
authorJohn Audia <graysky@archlinux.us>
Fri, 12 Nov 2021 20:20:08 +0000 (15:20 -0500)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 20 Nov 2021 17:53:14 +0000 (18:53 +0100)
Manually rebased:
    generic-backport/850-v5.13-usb-ehci-add-spurious-flag-to-disable-overcurrent-ch.patch

All other patches automatically rebased.

Signed-off-by: John Audia <graysky@archlinux.us>
include/kernel-version.mk
target/linux/bcm63xx/patches-5.4/206-USB-EHCI-allow-limiting-ports-for-ehci-platform.patch
target/linux/generic/backport-5.4/850-v5.13-usb-ehci-add-spurious-flag-to-disable-overcurrent-ch.patch
target/linux/layerscape/patches-5.4/820-usb-0014-MLK-17380-3-usb-move-EH-SINGLE_STEP_SET_FEATURE-impl.patch

index f393a370afc033999c19d2410620148c174822d9..44bfcaf052c114d839a907564797530f4356e733 100644 (file)
@@ -6,10 +6,10 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .158
+LINUX_VERSION-5.4 = .159
 LINUX_VERSION-5.10 = .80
 
-LINUX_KERNEL_HASH-5.4.158 = 6e018fecdc8fc24553756e582d83b82d65b10a6b03ef36262a24911f839b8d59
+LINUX_KERNEL_HASH-5.4.159 = d718325f4eab325dce4f82b88418f68ba130864118229539541331e0a4478643
 LINUX_KERNEL_HASH-5.10.80 = 477ce8f7624263e4346c0fc25ffc334af06bcac4d6bebdd5a7fe4681557fdb39
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 2fa5a002124b847e0631074f5ac4381d2f99e5de..59e832ea85a52cd6b5c8eb61bd06c3ae6982162e 100644 (file)
@@ -21,7 +21,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
 
 --- a/drivers/usb/host/ehci-hcd.c
 +++ b/drivers/usb/host/ehci-hcd.c
-@@ -678,6 +678,10 @@ int ehci_setup(struct usb_hcd *hcd)
+@@ -687,6 +687,10 @@ int ehci_setup(struct usb_hcd *hcd)
  
        /* cache this readonly data; minimize chip reads */
        ehci->hcs_params = ehci_readl(ehci, &ehci->caps->hcs_params);
index bda1d1df36dca539d2083756b499215c344edb0b..494c88a496dbdcceae155c05b745ebb01abf328e 100644 (file)
@@ -26,7 +26,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
 
 --- a/drivers/usb/host/ehci-hcd.c
 +++ b/drivers/usb/host/ehci-hcd.c
-@@ -651,7 +651,7 @@ static int ehci_run (struct usb_hcd *hcd
+@@ -660,7 +660,7 @@ static int ehci_run (struct usb_hcd *hcd
                "USB %x.%x started, EHCI %x.%02x%s\n",
                ((ehci->sbrn & 0xf0)>>4), (ehci->sbrn & 0x0f),
                temp >> 8, temp & 0xff,
@@ -57,7 +57,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
                        /*
 --- a/drivers/usb/host/ehci-platform.c
 +++ b/drivers/usb/host/ehci-platform.c
-@@ -319,6 +319,8 @@ static int ehci_platform_probe(struct pl
+@@ -325,6 +325,8 @@ static int ehci_platform_probe(struct pl
                hcd->has_tt = 1;
        if (pdata->reset_on_resume)
                priv->reset_on_resume = true;
@@ -68,10 +68,10 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
        if (ehci->big_endian_mmio) {
 --- a/drivers/usb/host/ehci.h
 +++ b/drivers/usb/host/ehci.h
-@@ -218,6 +218,7 @@ struct ehci_hcd {                  /* one per controlle
-       unsigned                frame_index_bug:1; /* MosChip (AKA NetMos) */
+@@ -219,6 +219,7 @@ struct ehci_hcd {                  /* one per controlle
        unsigned                need_oc_pp_cycle:1; /* MPC834X port power */
        unsigned                imx28_write_fix:1; /* For Freescale i.MX28 */
+       unsigned                is_aspeed:1;
 +      unsigned                spurious_oc:1;
  
        /* required for usb32 quirk */
index d43626577b87133a24b845f9f9de8d98b5c47925..f5bf467154a426707cacbba64a4c7709ba5cc428 100644 (file)
@@ -163,7 +163,7 @@ Signed-off-by: Peter Chen <peter.chen@nxp.com>
  
 --- a/drivers/usb/host/ehci-hcd.c
 +++ b/drivers/usb/host/ehci-hcd.c
-@@ -1245,6 +1245,10 @@ static const struct hc_driver ehci_hc_dr
+@@ -1254,6 +1254,10 @@ static const struct hc_driver ehci_hc_dr
         * device support
         */
        .free_dev =             ehci_remove_device,