kernel: bump 5.10 to 5.10.70
authorRui Salvaterra <rsalvaterra@gmail.com>
Thu, 30 Sep 2021 13:21:41 +0000 (14:21 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Thu, 30 Sep 2021 21:29:33 +0000 (22:29 +0100)
Deleted (upstreamed):
bcm53xx/patches-5.10/181-Revert-USB-bcma-Add-a-check-for-devm_gpiod_get.patch

Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
include/kernel-version.mk
target/linux/bcm27xx/patches-5.10/950-0138-usb-add-plumbing-for-updating-interrupt-endpoint-int.patch
target/linux/bcm27xx/patches-5.10/950-0139-xhci-implement-xhci_fixup_endpoint-for-interval-adju.patch
target/linux/bcm27xx/patches-5.10/950-0735-xhci-guard-accesses-to-ep_state-in-xhci_endpoint_res.patch
target/linux/bcm53xx/patches-5.10/181-Revert-USB-bcma-Add-a-check-for-devm_gpiod_get.patch [deleted file]
target/linux/generic/pending-5.10/100-compiler.h-only-include-asm-rwonce.h-for-kernel-code.patch
target/linux/generic/pending-5.10/811-pci_disable_usb_common_quirks.patch
target/linux/realtek/patches-5.10/704-drivers-net-phy-eee-support-for-rtl838x.patch

index 2bb55cb49aadc3f599fd543cb78496ad32bb09ea..216b2f636940f7381241474a5803cb2d5d57fa2a 100644 (file)
@@ -7,10 +7,10 @@ ifdef CONFIG_TESTING_KERNEL
 endif
 
 LINUX_VERSION-5.4 = .145
-LINUX_VERSION-5.10 = .69
+LINUX_VERSION-5.10 = .70
 
 LINUX_KERNEL_HASH-5.4.145 = 5cf7782ec2e91417edf0d5e6555da6d556962c8985e33ba9e7dadba5cbdc68f9
-LINUX_KERNEL_HASH-5.10.69 = 232f9ec53bccca768868831b7cc286f7d8bbbac9f481bbac1495700231a20cca
+LINUX_KERNEL_HASH-5.10.70 = 75736c33711d7f298889ee4981b18774882045323e5c46af9ad3b022082db232
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index a168528edf2b911deef412702aab3dccf8b4b98e..43da9308718a84c85a34cedce93c3ae1142afa2a 100644 (file)
@@ -81,7 +81,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
  extern int usb_driver_set_configuration(struct usb_device *udev, int config);
 --- a/include/linux/usb/hcd.h
 +++ b/include/linux/usb/hcd.h
-@@ -382,6 +382,11 @@ struct hc_driver {
+@@ -384,6 +384,11 @@ struct hc_driver {
                 * or bandwidth constraints.
                 */
        void    (*reset_bandwidth)(struct usb_hcd *, struct usb_device *);
@@ -93,7 +93,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
                /* Returns the hardware-chosen device address */
        int     (*address_device)(struct usb_hcd *, struct usb_device *udev);
                /* prepares the hardware to send commands to the device */
-@@ -443,6 +448,8 @@ extern void usb_hcd_unmap_urb_setup_for_
+@@ -445,6 +450,8 @@ extern void usb_hcd_unmap_urb_setup_for_
  extern void usb_hcd_unmap_urb_for_dma(struct usb_hcd *, struct urb *);
  extern void usb_hcd_flush_endpoint(struct usb_device *udev,
                struct usb_host_endpoint *ep);
index 406bb04d464580a21b8c4f99c27da0c2d52fdde2..391af473d1e2670ec43956c4d21171a80a9ffc63 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
 
 --- a/drivers/usb/host/xhci.c
 +++ b/drivers/usb/host/xhci.c
-@@ -1467,6 +1467,103 @@ command_cleanup:
+@@ -1468,6 +1468,103 @@ command_cleanup:
  }
  
  /*
@@ -119,7 +119,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
   * non-error returns are a promise to giveback() the urb later
   * we drop ownership so next owner (or urb unlink) can get it
   */
-@@ -5361,6 +5458,7 @@ static const struct hc_driver xhci_hc_dr
+@@ -5362,6 +5459,7 @@ static const struct hc_driver xhci_hc_dr
        .endpoint_reset =       xhci_endpoint_reset,
        .check_bandwidth =      xhci_check_bandwidth,
        .reset_bandwidth =      xhci_reset_bandwidth,
index d9a51605d4a0c4dc3a8fe2831b76ea226425a89d..9cf5aa2e990ead2c44042566184c11cb942dfc2a 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
 
 --- a/drivers/usb/host/xhci.c
 +++ b/drivers/usb/host/xhci.c
-@@ -3269,10 +3269,13 @@ static void xhci_endpoint_reset(struct u
+@@ -3270,10 +3270,13 @@ static void xhci_endpoint_reset(struct u
                return;
  
        /* Bail out if toggle is already being cleared by a endpoint reset */
@@ -30,7 +30,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
        /* Only interrupt and bulk ep's use data toggle, USB2 spec 5.5.4-> */
        if (usb_endpoint_xfer_control(&host_ep->desc) ||
            usb_endpoint_xfer_isoc(&host_ep->desc))
-@@ -3358,8 +3361,10 @@ static void xhci_endpoint_reset(struct u
+@@ -3359,8 +3362,10 @@ static void xhci_endpoint_reset(struct u
        xhci_free_command(xhci, cfg_cmd);
  cleanup:
        xhci_free_command(xhci, stop_cmd);
diff --git a/target/linux/bcm53xx/patches-5.10/181-Revert-USB-bcma-Add-a-check-for-devm_gpiod_get.patch b/target/linux/bcm53xx/patches-5.10/181-Revert-USB-bcma-Add-a-check-for-devm_gpiod_get.patch
deleted file mode 100644 (file)
index 9e42476..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <rafal@milecki.pl>
-Date: Tue, 31 Aug 2021 08:40:49 +0200
-Subject: [PATCH fix] Revert "USB: bcma: Add a check for devm_gpiod_get"
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-This reverts commit f3de5d857bb2362b00e2a8d4bc886cd49dcb66db.
-
-That commit broke USB on all routers that have USB always powered on and
-don't require toggling any GPIO. It's a majority of devices actually.
-
-The original code worked and seemed safe: vcc GPIO is optional and
-bcma_hci_platform_power_gpio() takes care of checking the pointer before
-using it.
-
-This revert fixes:
-[   10.801127] bcma_hcd: probe of bcma0:11 failed with error -2
-
-Cc: Chuhong Yuan <hslester96@gmail.com>
-Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
----
- drivers/usb/host/bcma-hcd.c | 5 +----
- 1 file changed, 1 insertion(+), 4 deletions(-)
-
---- a/drivers/usb/host/bcma-hcd.c
-+++ b/drivers/usb/host/bcma-hcd.c
-@@ -406,12 +406,9 @@ static int bcma_hcd_probe(struct bcma_de
-               return -ENOMEM;
-       usb_dev->core = core;
--      if (core->dev.of_node) {
-+      if (core->dev.of_node)
-               usb_dev->gpio_desc = devm_gpiod_get(&core->dev, "vcc",
-                                                   GPIOD_OUT_HIGH);
--              if (IS_ERR(usb_dev->gpio_desc))
--                      return PTR_ERR(usb_dev->gpio_desc);
--      }
-       switch (core->id.id) {
-       case BCMA_CORE_USB20_HOST:
index 39b98eac1b055c4e4c1155e7bc97f26fa25b1416..282c8196e5fdb88c25374da4e7506b2854ab50ef 100644 (file)
@@ -11,7 +11,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/include/linux/compiler.h
 +++ b/include/linux/compiler.h
-@@ -211,6 +211,8 @@ void ftrace_likely_update(struct ftrace_
+@@ -213,6 +213,8 @@ void ftrace_likely_update(struct ftrace_
        __v;                                                            \
  })
  
@@ -20,7 +20,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  #endif /* __KERNEL__ */
  
  /*
-@@ -243,6 +245,4 @@ static inline void *offset_to_ptr(const
+@@ -245,6 +247,4 @@ static inline void *offset_to_ptr(const
   */
  #define prevent_tail_call_optimization()      mb()
  
index 42a83978394d5b79c30a7b59b484ab08d9ea30e8..cf52fa36ca0662a34d00a773293ce21e56135ae6 100644 (file)
@@ -98,7 +98,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  #endif  /*  __LINUX_USB_PCI_QUIRKS_H  */
 --- a/include/linux/usb/hcd.h
 +++ b/include/linux/usb/hcd.h
-@@ -484,7 +484,14 @@ extern int usb_hcd_pci_probe(struct pci_
+@@ -486,7 +486,14 @@ extern int usb_hcd_pci_probe(struct pci_
  extern void usb_hcd_pci_remove(struct pci_dev *dev);
  extern void usb_hcd_pci_shutdown(struct pci_dev *dev);
  
index cca724293d608880096e99d120764ca8cad3f4bd..4fc31c4f4fdca212b125ac91be5fae3feb4ada05 100644 (file)
@@ -12,7 +12,7 @@
                return phy_ethtool_ksettings_set(pl->phydev, kset);
        }
  
-@@ -1700,8 +1705,11 @@ int phylink_ethtool_get_eee(struct phyli
+@@ -1726,8 +1731,11 @@ int phylink_ethtool_get_eee(struct phyli
  
        ASSERT_RTNL();
  
@@ -25,7 +25,7 @@
  
        return ret;
  }
-@@ -1718,8 +1726,11 @@ int phylink_ethtool_set_eee(struct phyli
+@@ -1744,8 +1752,11 @@ int phylink_ethtool_set_eee(struct phyli
  
        ASSERT_RTNL();