kernel: drop kmod-gpio-dev
authorStijn Tintel <stijn@linux-ipv6.be>
Fri, 1 Oct 2021 02:02:24 +0000 (05:02 +0300)
committerStijn Tintel <stijn@linux-ipv6.be>
Tue, 5 Oct 2021 20:30:48 +0000 (23:30 +0300)
The GPIO_DEVICE symbol belonged to a custom driver that was removed from
OpenWrt in 2012. The symbol never existed in the upstream kernel.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
package/kernel/linux/modules/other.mk

index 926fc67386f7eae04f9818988079546d06328489..fdcc089025afa47a64aac46f104bc684d72e43ff 100644 (file)
@@ -182,22 +182,6 @@ endef
 $(eval $(call KernelPackage,eeprom-at25))
 
 
-define KernelPackage/gpio-dev
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=Generic GPIO char device support
-  DEPENDS:=@GPIO_SUPPORT
-  KCONFIG:=CONFIG_GPIO_DEVICE
-  FILES:=$(LINUX_DIR)/drivers/char/gpio_dev.ko
-  AUTOLOAD:=$(call AutoLoad,40,gpio_dev)
-endef
-
-define KernelPackage/gpio-dev/description
- Kernel module to allows control of GPIO pins using a character device.
-endef
-
-$(eval $(call KernelPackage,gpio-dev))
-
-
 define KernelPackage/gpio-f7188x
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Fintek F718xx/F818xx GPIO Support