libnfnetlink: update to 1.0.2
authorNick Hainke <vincent@systemli.org>
Tue, 5 Apr 2022 13:26:24 +0000 (15:26 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 9 Apr 2022 16:33:24 +0000 (18:33 +0200)
Changes:

c63f193 bump version to 1.0.2
3cffa84 libnfnetlink: Check getsockname() return code
90ba679 include: Silence gcc warning in linux_list.h
bb4f6c8 Make it clear that this library is deprecated
e46569c Minimally resurrect doxygen documentation
5087de4 libnfnetlink: hide private symbols
62ca426 autogen: don't convert __u16 to u_int16_t
efa1d8e src: Use stdint types everywhere
7a1a07c include: Sync with kernel headers
7633f0c libnfnetlink: initialize attribute padding to resolve valgrind warnings
94b68f3 configure: uclinux is also linux
617fe82 src: get source code license header in sync with current licensing terms
97a3960 build: resolve automake-1.12 warnings

Removed the patch 100-missing_include.patch, libnfnetlink compiles fine
with musl without this patch.

Signed-off-by: Nick Hainke <vincent@systemli.org>
package/libs/libnfnetlink/Makefile
package/libs/libnfnetlink/patches/100-missing_include.patch [deleted file]

index bc64ff111d1f37e64463d519736d013679ccebf0..57bb0cdb981d78671f9aa2d98adfe17ef067c43b 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libnfnetlink
-PKG_VERSION:=1.0.1
-PKG_RELEASE:=4
+PKG_VERSION:=1.0.2
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
        http://www.netfilter.org/projects/libnfnetlink/files/ \
        ftp://ftp.netfilter.org/pub/libnfnetlink/
-PKG_HASH:=f270e19de9127642d2a11589ef2ec97ef90a649a74f56cf9a96306b04817b51a
+PKG_HASH:=b064c7c3d426efb4786e60a8e6859b82ee2f2c5e49ffeea640cfe4fe33cbc376
 PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
 PKG_LICENSE:=GPL-2.0+
 
diff --git a/package/libs/libnfnetlink/patches/100-missing_include.patch b/package/libs/libnfnetlink/patches/100-missing_include.patch
deleted file mode 100644 (file)
index 163307d..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/include/libnfnetlink/libnfnetlink.h
-+++ b/include/libnfnetlink/libnfnetlink.h
-@@ -15,6 +15,7 @@
- #define aligned_u64 unsigned long long __attribute__((aligned(8)))
- #endif
-+#include <sys/types.h>
- #include <sys/socket.h>       /* for sa_family_t */
- #include <linux/netlink.h>
- #include <libnfnetlink/linux_nfnetlink.h>
---- a/include/libnfnetlink/linux_nfnetlink.h
-+++ b/include/libnfnetlink/linux_nfnetlink.h
-@@ -1,6 +1,6 @@
- #ifndef _NFNETLINK_H
- #define _NFNETLINK_H
--#include <linux/types.h>
-+#include <sys/types.h>
- #include <libnfnetlink/linux_nfnetlink_compat.h>
- enum nfnetlink_groups {