iw: Update to version 5.16
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 20 Nov 2021 23:11:24 +0000 (00:11 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 14 Dec 2021 21:59:10 +0000 (22:59 +0100)
Revert a commit to allow providing CFLAGS and LIBS from OpenWrt package
Makefile.

This downgrades the nl80211.h to kernel 5.15 and removes FILS_CRYPTO_OFFLOAD.
This is needed to make it compatible with our patched mac80211 from
kernel 5.15

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/network/utils/iw/Makefile
package/network/utils/iw/patches/001-nl80211_h_sync.patch
package/network/utils/iw/patches/010-Revert-iw-allow-specifying-CFLAGS-LIBS-externally.patch [new file with mode: 0644]
package/network/utils/iw/patches/200-reduce_size.patch

index 8e11046189c0464e88f9c91adfa12bfa245f2bdb..da2b5564168f94b60c854860b9435ddcea225eae 100644 (file)
@@ -8,13 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iw
-PKG_VERSION:=5.9-8fab0c9e
-PKG_RELEASE:=$(AUTORELEASE)
-
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/linux/kernel/git/jberg/iw.git
-PKG_SOURCE_VERSION:=8fab0c9ee9db217587a58efcc37421c86edcb638
-PKG_MIRROR_HASH:=797b322bc03952f3127ae0a7da476c14ada1bbe9a9ae234a56dd6f864c568e16
+PKG_VERSION:=5.16
+PKG_RELEASE:=1
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=@KERNEL/software/network/iw
+PKG_HASH:=4c44e42762f903f9094ba5a598998c800a97a62afd6fd31ec1e0a799e308659c
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 PKG_LICENSE:=GPL-2.0
index f788e6915f963c7ae5afa8f776d4c525d929e27d..6d81dd0da1eff37ee136cde2c9ad9cfeccd2d099 100644 (file)
 --- a/nl80211.h
 +++ b/nl80211.h
-@@ -11,7 +11,7 @@
-  * Copyright 2008 Jouni Malinen <jouni.malinen@atheros.com>
-  * Copyright 2008 Colin McCabe <colin@cozybit.com>
-  * Copyright 2015-2017        Intel Deutschland GmbH
-- * Copyright (C) 2018-2020 Intel Corporation
-+ * Copyright (C) 2018-2021 Intel Corporation
-  *
-  * Permission to use, copy, modify, and/or distribute this software for any
-  * purpose with or without fee is hereby granted, provided that the above
-@@ -655,6 +655,9 @@
-  *    When a security association was established on an 802.1X network using
-  *    fast transition, this event should be followed by an
-  *    %NL80211_CMD_PORT_AUTHORIZED event.
-+ *    Following a %NL80211_CMD_ROAM event userspace can issue
-+ *    %NL80211_CMD_GET_SCAN in order to obtain the scan information for the
-+ *    new BSS the card/driver roamed to.
-  * @NL80211_CMD_DISCONNECT: drop a given connection; also used to notify
-  *    userspace that a connection was dropped by the AP or due to other
-  *    reasons, for this the %NL80211_ATTR_DISCONNECTED_BY_AP and
-@@ -757,7 +760,8 @@
-  *    of any other interfaces, and other interfaces will again take
-  *    precedence when they are used.
+@@ -301,29 +301,6 @@
+  */
+ /**
+- * DOC: FILS shared key crypto offload
+- *
+- * This feature is applicable to drivers running in AP mode.
+- *
+- * FILS shared key crypto offload can be advertised by drivers by setting
+- * @NL80211_EXT_FEATURE_FILS_CRYPTO_OFFLOAD flag. The drivers that support
+- * FILS shared key crypto offload should be able to encrypt and decrypt
+- * association frames for FILS shared key authentication as per IEEE 802.11ai.
+- * With this capability, for FILS key derivation, drivers depend on userspace.
+- *
+- * After FILS key derivation, userspace shares the FILS AAD details with the
+- * driver and the driver stores the same to use in decryption of association
+- * request and in encryption of association response. The below parameters
+- * should be given to the driver in %NL80211_CMD_SET_FILS_AAD.
+- *    %NL80211_ATTR_MAC - STA MAC address, used for storing FILS AAD per STA
+- *    %NL80211_ATTR_FILS_KEK - Used for encryption or decryption
+- *    %NL80211_ATTR_FILS_NONCES - Used for encryption or decryption
+- *                    (STA Nonce 16 bytes followed by AP Nonce 16 bytes)
+- *
+- * Once the association is done, the driver cleans the FILS AAD data.
+- */
+-
+-/**
+  * enum nl80211_commands - supported nl80211 commands
   *
-- * @NL80211_CMD_SET_WDS_PEER: Set the MAC address of the peer on a WDS interface.
-+ * @NL80211_CMD_SET_WDS_PEER: Set the MAC address of the peer on a WDS interface
-+ *    (no longer supported).
+  * @NL80211_CMD_UNSPEC: unspecified command to catch errors
+@@ -360,10 +337,7 @@
+  * @NL80211_CMD_DEL_INTERFACE: Virtual interface was deleted, has attributes
+  *    %NL80211_ATTR_IFINDEX and %NL80211_ATTR_WIPHY. Can also be sent from
+  *    userspace to request deletion of a virtual interface, then requires
+- *    attribute %NL80211_ATTR_IFINDEX. If multiple BSSID advertisements are
+- *    enabled using %NL80211_ATTR_MBSSID_CONFIG, %NL80211_ATTR_MBSSID_ELEMS,
+- *    and if this command is used for the transmitting interface, then all
+- *    the non-transmitting interfaces are deleted as well.
++ *    attribute %NL80211_ATTR_IFINDEX.
   *
-  * @NL80211_CMD_SET_MULTICAST_TO_UNICAST: Configure if this AP should perform
-  *    multicast to unicast conversion. When enabled, all multicast packets
-@@ -1177,6 +1181,25 @@
-  *    includes the contents of the frame. %NL80211_ATTR_ACK flag is included
-  *    if the recipient acknowledged the frame.
+  * @NL80211_CMD_GET_KEY: Get sequence counter information for a key specified
+  *    by %NL80211_ATTR_KEY_IDX and/or %NL80211_ATTR_MAC.
+@@ -1226,12 +1200,6 @@
+  * @NL80211_CMD_COLOR_CHANGE_COMPLETED: Notify userland that the color change
+  *    has completed
   *
-+ * @NL80211_CMD_SET_SAR_SPECS: SAR power limitation configuration is
-+ *    passed using %NL80211_ATTR_SAR_SPEC. %NL80211_ATTR_WIPHY is used to
-+ *    specify the wiphy index to be applied to.
-+ *
-+ * @NL80211_CMD_OBSS_COLOR_COLLISION: This notification is sent out whenever
-+ *    mac80211/drv detects a bss color collision.
-+ *
-+ * @NL80211_CMD_COLOR_CHANGE_REQUEST: This command is used to indicate that
-+ *    userspace wants to change the BSS color.
-+ *
-+ * @NL80211_CMD_COLOR_CHANGE_STARTED: Notify userland, that a color change has
-+ *    started
-+ *
-+ * @NL80211_CMD_COLOR_CHANGE_ABORTED: Notify userland, that the color change has
-+ *    been aborted
-+ *
-+ * @NL80211_CMD_COLOR_CHANGE_COMPLETED: Notify userland that the color change
-+ *    has completed
-+ *
+- * @NL80211_CMD_SET_FILS_AAD: Set FILS AAD data to the driver using -
+- *    &NL80211_ATTR_MAC - for STA MAC address
+- *    &NL80211_ATTR_FILS_KEK - for KEK
+- *    &NL80211_ATTR_FILS_NONCES - for FILS Nonces
+- *            (STA Nonce 16 bytes followed by AP Nonce 16 bytes)
+- *
   * @NL80211_CMD_MAX: highest used command number
   * @__NL80211_CMD_AFTER_LAST: internal use
   */
-@@ -1407,6 +1430,16 @@ enum nl80211_commands {
+@@ -1472,8 +1440,6 @@ enum nl80211_commands {
+       NL80211_CMD_COLOR_CHANGE_ABORTED,
+       NL80211_CMD_COLOR_CHANGE_COMPLETED,
  
-       NL80211_CMD_CONTROL_PORT_FRAME_TX_STATUS,
-+      NL80211_CMD_SET_SAR_SPECS,
-+
-+      NL80211_CMD_OBSS_COLOR_COLLISION,
-+
-+      NL80211_CMD_COLOR_CHANGE_REQUEST,
-+
-+      NL80211_CMD_COLOR_CHANGE_STARTED,
-+      NL80211_CMD_COLOR_CHANGE_ABORTED,
-+      NL80211_CMD_COLOR_CHANGE_COMPLETED,
-+
+-      NL80211_CMD_SET_FILS_AAD,
+-
        /* add new commands above here */
  
        /* used to define NL80211_CMD_MAX below */
-@@ -1750,8 +1783,9 @@ enum nl80211_commands {
-  *    specify just a single bitrate, which is to be used for the beacon.
-  *    The driver must also specify support for this with the extended
-  *    features NL80211_EXT_FEATURE_BEACON_RATE_LEGACY,
-- *    NL80211_EXT_FEATURE_BEACON_RATE_HT and
-- *    NL80211_EXT_FEATURE_BEACON_RATE_VHT.
-+ *    NL80211_EXT_FEATURE_BEACON_RATE_HT,
-+ *    NL80211_EXT_FEATURE_BEACON_RATE_VHT and
-+ *    NL80211_EXT_FEATURE_BEACON_RATE_HE.
-  *
-  * @NL80211_ATTR_FRAME_MATCH: A binary attribute which typically must contain
-  *    at least one byte, currently used with @NL80211_CMD_REGISTER_FRAME.
-@@ -1955,8 +1989,15 @@ enum nl80211_commands {
-  * @NL80211_ATTR_PROBE_RESP: Probe Response template data. Contains the entire
-  *    probe-response frame. The DA field in the 802.11 header is zero-ed out,
-  *    to be filled by the FW.
-- * @NL80211_ATTR_DISABLE_HT:  Force HT capable interfaces to disable
-- *      this feature.  Currently, only supported in mac80211 drivers.
-+ * @NL80211_ATTR_DISABLE_HT: Force HT capable interfaces to disable
-+ *      this feature during association. This is a flag attribute.
-+ *    Currently only supported in mac80211 drivers.
-+ * @NL80211_ATTR_DISABLE_VHT: Force VHT capable interfaces to disable
-+ *      this feature during association. This is a flag attribute.
-+ *    Currently only supported in mac80211 drivers.
-+ * @NL80211_ATTR_DISABLE_HE: Force HE capable interfaces to disable
-+ *      this feature during association. This is a flag attribute.
-+ *    Currently only supported in mac80211 drivers.
-  * @NL80211_ATTR_HT_CAPABILITY_MASK: Specify which bits of the
-  *      ATTR_HT_CAPABILITY to which attention should be paid.
-  *      Currently, only mac80211 NICs support this feature.
-@@ -2077,7 +2118,8 @@ enum nl80211_commands {
-  *    until the channel switch event.
-  * @NL80211_ATTR_CH_SWITCH_BLOCK_TX: flag attribute specifying that transmission
-  *    must be blocked on the current channel (before the channel switch
-- *    operation).
-+ *    operation). Also included in the channel switch started event if quiet
-+ *    was requested by the AP.
-  * @NL80211_ATTR_CSA_IES: Nested set of attributes containing the IE information
-  *    for the time while performing a channel switch.
-  * @NL80211_ATTR_CNTDWN_OFFS_BEACON: An array of offsets (u16) to the channel
-@@ -2527,6 +2569,33 @@ enum nl80211_commands {
-  *    override mask. Used with NL80211_ATTR_S1G_CAPABILITY in
-  *    NL80211_CMD_ASSOCIATE or NL80211_CMD_CONNECT.
+@@ -2627,17 +2593,8 @@ enum nl80211_commands {
+  * @NL80211_ATTR_COLOR_CHANGE_ELEMS: Nested set of attributes containing the IE
+  *    information for the time while performing a color switch.
   *
-+ * @NL80211_ATTR_SAE_PWE: Indicates the mechanism(s) allowed for SAE PWE
-+ *    derivation in WPA3-Personal networks which are using SAE authentication.
-+ *    This is a u8 attribute that encapsulates one of the values from
-+ *    &enum nl80211_sae_pwe_mechanism.
-+ *
-+ * @NL80211_ATTR_SAR_SPEC: SAR power limitation specification when
-+ *    used with %NL80211_CMD_SET_SAR_SPECS. The message contains fields
-+ *    of %nl80211_sar_attrs which specifies the sar type and related
-+ *    sar specs. Sar specs contains array of %nl80211_sar_specs_attrs.
-+ *
-+ * @NL80211_ATTR_RECONNECT_REQUESTED: flag attribute, used with deauth and
-+ *    disassoc events to indicate that an immediate reconnect to the AP
-+ *    is desired.
-+ *
-+ * @NL80211_ATTR_OBSS_COLOR_BITMAP: bitmap of the u64 BSS colors for the
-+ *    %NL80211_CMD_OBSS_COLOR_COLLISION event.
-+ *
-+ * @NL80211_ATTR_COLOR_CHANGE_COUNT: u8 attribute specifying the number of TBTT's
-+ *    until the color switch event.
-+ * @NL80211_ATTR_COLOR_CHANGE_COLOR: u8 attribute specifying the color that we are
-+ *    switching to
-+ * @NL80211_ATTR_COLOR_CHANGE_ELEMS: Nested set of attributes containing the IE
-+ *    information for the time while performing a color switch.
-+ *
+- * @NL80211_ATTR_MBSSID_CONFIG: Nested attribute for multiple BSSID
+- *    advertisements (MBSSID) parameters in AP mode.
+- *    Kernel uses this attribute to indicate the driver's support for MBSSID
+- *    and enhanced multi-BSSID advertisements (EMA AP) to the userspace.
+- *    Userspace should use this attribute to configure per interface MBSSID
+- *    parameters.
+- *    See &enum nl80211_mbssid_config_attributes for details.
+- *
+- * @NL80211_ATTR_MBSSID_ELEMS: Nested parameter to pass multiple BSSID elements.
+- *    Mandatory parameter for the transmitting interface to enable MBSSID.
+- *    Optional for the non-transmitting interfaces.
 + * @NL80211_ATTR_WIPHY_ANTENNA_GAIN: Configured antenna gain. Used to reduce
 + *    transmit power to stay within regulatory limits. u32, dBi.
-+ *
+  *
   * @NUM_NL80211_ATTR: total number of nl80211_attrs available
   * @NL80211_ATTR_MAX: highest attribute number currently defined
-  * @__NL80211_ATTR_AFTER_LAST: internal use
-@@ -3016,6 +3085,22 @@ enum nl80211_attrs {
-       NL80211_ATTR_S1G_CAPABILITY,
-       NL80211_ATTR_S1G_CAPABILITY_MASK,
+@@ -3142,8 +3099,7 @@ enum nl80211_attrs {
+       NL80211_ATTR_COLOR_CHANGE_COLOR,
+       NL80211_ATTR_COLOR_CHANGE_ELEMS,
  
-+      NL80211_ATTR_SAE_PWE,
-+
-+      NL80211_ATTR_RECONNECT_REQUESTED,
-+
-+      NL80211_ATTR_SAR_SPEC,
-+
-+      NL80211_ATTR_DISABLE_HE,
-+
-+      NL80211_ATTR_OBSS_COLOR_BITMAP,
-+
-+      NL80211_ATTR_COLOR_CHANGE_COUNT,
-+      NL80211_ATTR_COLOR_CHANGE_COLOR,
-+      NL80211_ATTR_COLOR_CHANGE_ELEMS,
-+
+-      NL80211_ATTR_MBSSID_CONFIG,
+-      NL80211_ATTR_MBSSID_ELEMS,
 +      NL80211_ATTR_WIPHY_ANTENNA_GAIN,
-+
        /* add attributes here, update the policy in nl80211.c */
  
-       __NL80211_ATTR_AFTER_LAST,
-@@ -3613,6 +3698,8 @@ enum nl80211_mpath_info {
-  *     defined
-  * @NL80211_BAND_IFTYPE_ATTR_HE_6GHZ_CAPA: HE 6GHz band capabilities (__le16),
-  *    given for all 6 GHz band channels
-+ * @NL80211_BAND_IFTYPE_ATTR_VENDOR_ELEMS: vendor element capabilities that are
-+ *    advertised on this band/for this iftype (binary)
-  * @__NL80211_BAND_IFTYPE_ATTR_AFTER_LAST: internal use
+@@ -4978,7 +4934,6 @@ enum nl80211_txrate_gi {
+  * @NL80211_BAND_60GHZ: around 60 GHz band (58.32 - 69.12 GHz)
+  * @NL80211_BAND_6GHZ: around 6 GHz band (5.9 - 7.2 GHz)
+  * @NL80211_BAND_S1GHZ: around 900MHz, supported by S1G PHYs
+- * @NL80211_BAND_LC: light communication band (placeholder)
+  * @NUM_NL80211_BANDS: number of bands, avoid using this in userspace
+  *    since newer kernel versions may support more bands
   */
- enum nl80211_band_iftype_attr {
-@@ -3624,6 +3711,7 @@ enum nl80211_band_iftype_attr {
-       NL80211_BAND_IFTYPE_ATTR_HE_CAP_MCS_SET,
-       NL80211_BAND_IFTYPE_ATTR_HE_CAP_PPE,
-       NL80211_BAND_IFTYPE_ATTR_HE_6GHZ_CAPA,
-+      NL80211_BAND_IFTYPE_ATTR_VENDOR_ELEMS,
+@@ -4988,7 +4943,6 @@ enum nl80211_band {
+       NL80211_BAND_60GHZ,
+       NL80211_BAND_6GHZ,
+       NL80211_BAND_S1GHZ,
+-      NL80211_BAND_LC,
  
-       /* keep last */
-       __NL80211_BAND_IFTYPE_ATTR_AFTER_LAST,
-@@ -5896,6 +5984,22 @@ enum nl80211_feature_flags {
-  * @NL80211_EXT_FEATURE_UNSOL_BCAST_PROBE_RESP: Driver/device supports
-  *    unsolicited broadcast probe response transmission
+       NUM_NL80211_BANDS,
+ };
+@@ -6046,11 +6000,6 @@ enum nl80211_feature_flags {
+  * @NL80211_EXT_FEATURE_BSS_COLOR: The driver supports BSS color collision
+  *    detection and change announcemnts.
   *
-+ * @NL80211_EXT_FEATURE_BEACON_RATE_HE: Driver supports beacon rate
-+ *    configuration (AP/mesh) with HE rates.
-+ *
-+ * @NL80211_EXT_FEATURE_SECURE_LTF: Device supports secure LTF measurement
-+ *      exchange protocol.
-+ *
-+ * @NL80211_EXT_FEATURE_SECURE_RTT: Device supports secure RTT measurement
-+ *      exchange protocol.
-+ *
-+ * @NL80211_EXT_FEATURE_PROT_RANGE_NEGO_AND_MEASURE: Device supports management
-+ *      frame protection for all management frames exchanged during the
-+ *      negotiation and range measurement procedure.
-+ *
-+ * @NL80211_EXT_FEATURE_BSS_COLOR: The driver supports BSS color collision
-+ *    detection and change announcemnts.
-+ *
+- * @NL80211_EXT_FEATURE_FILS_CRYPTO_OFFLOAD: Driver running in AP mode supports
+- *    FILS encryption and decryption for (Re)Association Request and Response
+- *    frames. Userspace has to share FILS AAD details to the driver by using
+- *    @NL80211_CMD_SET_FILS_AAD.
+- *
   * @NUM_NL80211_EXT_FEATURES: number of extended features.
   * @MAX_NL80211_EXT_FEATURES: highest extended feature index.
   */
-@@ -5956,6 +6060,11 @@ enum nl80211_ext_feature_index {
-       NL80211_EXT_FEATURE_SAE_OFFLOAD_AP,
-       NL80211_EXT_FEATURE_FILS_DISCOVERY,
-       NL80211_EXT_FEATURE_UNSOL_BCAST_PROBE_RESP,
-+      NL80211_EXT_FEATURE_BEACON_RATE_HE,
-+      NL80211_EXT_FEATURE_SECURE_LTF,
-+      NL80211_EXT_FEATURE_SECURE_RTT,
-+      NL80211_EXT_FEATURE_PROT_RANGE_NEGO_AND_MEASURE,
-+      NL80211_EXT_FEATURE_BSS_COLOR,
+@@ -6116,7 +6065,6 @@ enum nl80211_ext_feature_index {
+       NL80211_EXT_FEATURE_SECURE_RTT,
+       NL80211_EXT_FEATURE_PROT_RANGE_NEGO_AND_MEASURE,
+       NL80211_EXT_FEATURE_BSS_COLOR,
+-      NL80211_EXT_FEATURE_FILS_CRYPTO_OFFLOAD,
  
        /* add new features before the definition below */
        NUM_NL80211_EXT_FEATURES,
-@@ -6253,11 +6362,13 @@ struct nl80211_vendor_cmd_info {
-  * @NL80211_TDLS_PEER_HT: TDLS peer is HT capable.
-  * @NL80211_TDLS_PEER_VHT: TDLS peer is VHT capable.
-  * @NL80211_TDLS_PEER_WMM: TDLS peer is WMM capable.
-+ * @NL80211_TDLS_PEER_HE: TDLS peer is HE capable.
-  */
- enum nl80211_tdls_peer_capability {
-       NL80211_TDLS_PEER_HT = 1<<0,
-       NL80211_TDLS_PEER_VHT = 1<<1,
-       NL80211_TDLS_PEER_WMM = 1<<2,
-+      NL80211_TDLS_PEER_HE = 1<<3,
+@@ -7406,60 +7354,4 @@ enum nl80211_sar_specs_attrs {
+       NL80211_SAR_ATTR_SPECS_MAX = __NL80211_SAR_ATTR_SPECS_LAST - 1,
  };
  
- /**
-@@ -6849,6 +6960,12 @@ enum nl80211_peer_measurement_ftm_capa {
-  *      if neither %NL80211_PMSR_FTM_REQ_ATTR_TRIGGER_BASED nor
-  *    %NL80211_PMSR_FTM_REQ_ATTR_NON_TRIGGER_BASED is set, EDCA based
-  *    ranging will be used.
-+ * @NL80211_PMSR_FTM_REQ_ATTR_LMR_FEEDBACK: negotiate for LMR feedback. Only
-+ *    valid if either %NL80211_PMSR_FTM_REQ_ATTR_TRIGGER_BASED or
-+ *    %NL80211_PMSR_FTM_REQ_ATTR_NON_TRIGGER_BASED is set.
-+ * @NL80211_PMSR_FTM_REQ_ATTR_BSS_COLOR: optional. The BSS color of the
-+ *    responder. Only valid if %NL80211_PMSR_FTM_REQ_ATTR_NON_TRIGGER_BASED
-+ *    or %NL80211_PMSR_FTM_REQ_ATTR_TRIGGER_BASED is set.
-  *
-  * @NUM_NL80211_PMSR_FTM_REQ_ATTR: internal
-  * @NL80211_PMSR_FTM_REQ_ATTR_MAX: highest attribute number
-@@ -6867,6 +6984,8 @@ enum nl80211_peer_measurement_ftm_req {
-       NL80211_PMSR_FTM_REQ_ATTR_REQUEST_CIVICLOC,
-       NL80211_PMSR_FTM_REQ_ATTR_TRIGGER_BASED,
-       NL80211_PMSR_FTM_REQ_ATTR_NON_TRIGGER_BASED,
-+      NL80211_PMSR_FTM_REQ_ATTR_LMR_FEEDBACK,
-+      NL80211_PMSR_FTM_REQ_ATTR_BSS_COLOR,
-       /* keep last */
-       NUM_NL80211_PMSR_FTM_REQ_ATTR,
-@@ -7124,4 +7243,115 @@ enum nl80211_unsol_bcast_probe_resp_attr
-       NL80211_UNSOL_BCAST_PROBE_RESP_ATTR_MAX =
-               __NL80211_UNSOL_BCAST_PROBE_RESP_ATTR_LAST - 1
- };
-+
-+/**
-+ * enum nl80211_sae_pwe_mechanism - The mechanism(s) allowed for SAE PWE
-+ *    derivation. Applicable only when WPA3-Personal SAE authentication is
-+ *    used.
-+ *
-+ * @NL80211_SAE_PWE_UNSPECIFIED: not specified, used internally to indicate that
-+ *    attribute is not present from userspace.
-+ * @NL80211_SAE_PWE_HUNT_AND_PECK: hunting-and-pecking loop only
-+ * @NL80211_SAE_PWE_HASH_TO_ELEMENT: hash-to-element only
-+ * @NL80211_SAE_PWE_BOTH: both hunting-and-pecking loop and hash-to-element
-+ *    can be used.
-+ */
-+enum nl80211_sae_pwe_mechanism {
-+      NL80211_SAE_PWE_UNSPECIFIED,
-+      NL80211_SAE_PWE_HUNT_AND_PECK,
-+      NL80211_SAE_PWE_HASH_TO_ELEMENT,
-+      NL80211_SAE_PWE_BOTH,
-+};
-+
-+/**
-+ * enum nl80211_sar_type - type of SAR specs
-+ *
-+ * @NL80211_SAR_TYPE_POWER: power limitation specified in 0.25dBm unit
-+ *
-+ */
-+enum nl80211_sar_type {
-+      NL80211_SAR_TYPE_POWER,
-+
-+      /* add new type here */
-+
-+      /* Keep last */
-+      NUM_NL80211_SAR_TYPE,
-+};
-+
-+/**
-+ * enum nl80211_sar_attrs - Attributes for SAR spec
-+ *
-+ * @NL80211_SAR_ATTR_TYPE: the SAR type as defined in &enum nl80211_sar_type.
-+ *
-+ * @NL80211_SAR_ATTR_SPECS: Nested array of SAR power
-+ *    limit specifications. Each specification contains a set
-+ *    of %nl80211_sar_specs_attrs.
-+ *
-+ *    For SET operation, it contains array of %NL80211_SAR_ATTR_SPECS_POWER
-+ *    and %NL80211_SAR_ATTR_SPECS_RANGE_INDEX.
-+ *
-+ *    For sar_capa dump, it contains array of
-+ *    %NL80211_SAR_ATTR_SPECS_START_FREQ
-+ *    and %NL80211_SAR_ATTR_SPECS_END_FREQ.
-+ *
-+ * @__NL80211_SAR_ATTR_LAST: Internal
-+ * @NL80211_SAR_ATTR_MAX: highest sar attribute
-+ *
-+ * These attributes are used with %NL80211_CMD_SET_SAR_SPEC
-+ */
-+enum nl80211_sar_attrs {
-+      __NL80211_SAR_ATTR_INVALID,
-+
-+      NL80211_SAR_ATTR_TYPE,
-+      NL80211_SAR_ATTR_SPECS,
-+
-+      __NL80211_SAR_ATTR_LAST,
-+      NL80211_SAR_ATTR_MAX = __NL80211_SAR_ATTR_LAST - 1,
-+};
-+
-+/**
-+ * enum nl80211_sar_specs_attrs - Attributes for SAR power limit specs
-+ *
-+ * @NL80211_SAR_ATTR_SPECS_POWER: Required (s32)value to specify the actual
-+ *    power limit value in units of 0.25 dBm if type is
-+ *    NL80211_SAR_TYPE_POWER. (i.e., a value of 44 represents 11 dBm).
-+ *    0 means userspace doesn't have SAR limitation on this associated range.
-+ *
-+ * @NL80211_SAR_ATTR_SPECS_RANGE_INDEX: Required (u32) value to specify the
-+ *    index of exported freq range table and the associated power limitation
-+ *    is applied to this range.
-+ *
-+ *    Userspace isn't required to set all the ranges advertised by WLAN driver,
-+ *    and userspace can skip some certain ranges. These skipped ranges don't
-+ *    have SAR limitations, and they are same as setting the
-+ *    %NL80211_SAR_ATTR_SPECS_POWER to any unreasonable high value because any
-+ *    value higher than regulatory allowed value just means SAR power
-+ *    limitation is removed, but it's required to set at least one range.
-+ *    It's not allowed to set duplicated range in one SET operation.
-+ *
-+ *    Every SET operation overwrites previous SET operation.
-+ *
-+ * @NL80211_SAR_ATTR_SPECS_START_FREQ: Required (u32) value to specify the start
-+ *    frequency of this range edge when registering SAR capability to wiphy.
-+ *    It's not a channel center frequency. The unit is kHz.
-+ *
-+ * @NL80211_SAR_ATTR_SPECS_END_FREQ: Required (u32) value to specify the end
-+ *    frequency of this range edge when registering SAR capability to wiphy.
-+ *    It's not a channel center frequency. The unit is kHz.
-+ *
-+ * @__NL80211_SAR_ATTR_SPECS_LAST: Internal
-+ * @NL80211_SAR_ATTR_SPECS_MAX: highest sar specs attribute
-+ */
-+enum nl80211_sar_specs_attrs {
-+      __NL80211_SAR_ATTR_SPECS_INVALID,
-+
-+      NL80211_SAR_ATTR_SPECS_POWER,
-+      NL80211_SAR_ATTR_SPECS_RANGE_INDEX,
-+      NL80211_SAR_ATTR_SPECS_START_FREQ,
-+      NL80211_SAR_ATTR_SPECS_END_FREQ,
-+
-+      __NL80211_SAR_ATTR_SPECS_LAST,
-+      NL80211_SAR_ATTR_SPECS_MAX = __NL80211_SAR_ATTR_SPECS_LAST - 1,
-+};
-+
+-/**
+- * enum nl80211_mbssid_config_attributes - multiple BSSID (MBSSID) and enhanced
+- * multi-BSSID advertisements (EMA) in AP mode.
+- * Kernel uses some of these attributes to advertise driver's support for
+- * MBSSID and EMA.
+- * Remaining attributes should be used by the userspace to configure the
+- * features.
+- *
+- * @__NL80211_MBSSID_CONFIG_ATTR_INVALID: Invalid
+- *
+- * @NL80211_MBSSID_CONFIG_ATTR_MAX_INTERFACES: Used by the kernel to advertise
+- *    the maximum number of MBSSID interfaces supported by the driver.
+- *    Driver should indicate MBSSID support by setting
+- *    wiphy->mbssid_max_interfaces to a value more than or equal to 2.
+- *
+- * @NL80211_MBSSID_CONFIG_ATTR_MAX_EMA_PROFILE_PERIODICITY: Used by the kernel
+- *    to advertise the maximum profile periodicity supported by the driver
+- *    if EMA is enabled. Driver should indicate EMA support to the userspace
+- *    by setting wiphy->ema_max_profile_periodicity to
+- *    a non-zero value.
+- *
+- * @NL80211_MBSSID_CONFIG_ATTR_INDEX: Mandatory parameter to pass the index of
+- *    this BSS (u8) in the multiple BSSID set.
+- *    Value must be set to 0 for the transmitting interface and non-zero for
+- *    all non-transmitting interfaces. The userspace will be responsible
+- *    for using unique indices for the interfaces.
+- *    Range: 0 to wiphy->mbssid_max_interfaces-1.
+- *
+- * @NL80211_MBSSID_CONFIG_ATTR_TX_IFINDEX: Mandatory parameter for
+- *    a non-transmitted profile which provides the interface index (u32) of
+- *    the transmitted profile. The value must match one of the interface
+- *    indices advertised by the kernel. Optional if the interface being set up
+- *    is the transmitting one, however, if provided then the value must match
+- *    the interface index of the same.
+- *
+- * @NL80211_MBSSID_CONFIG_ATTR_EMA: Flag used to enable EMA AP feature.
+- *    Setting this flag is permitted only if the driver advertises EMA support
+- *    by setting wiphy->ema_max_profile_periodicity to non-zero.
+- *
+- * @__NL80211_MBSSID_CONFIG_ATTR_LAST: Internal
+- * @NL80211_MBSSID_CONFIG_ATTR_MAX: highest attribute
+- */
+-enum nl80211_mbssid_config_attributes {
+-      __NL80211_MBSSID_CONFIG_ATTR_INVALID,
+-
+-      NL80211_MBSSID_CONFIG_ATTR_MAX_INTERFACES,
+-      NL80211_MBSSID_CONFIG_ATTR_MAX_EMA_PROFILE_PERIODICITY,
+-      NL80211_MBSSID_CONFIG_ATTR_INDEX,
+-      NL80211_MBSSID_CONFIG_ATTR_TX_IFINDEX,
+-      NL80211_MBSSID_CONFIG_ATTR_EMA,
+-
+-      /* keep last */
+-      __NL80211_MBSSID_CONFIG_ATTR_LAST,
+-      NL80211_MBSSID_CONFIG_ATTR_MAX = __NL80211_MBSSID_CONFIG_ATTR_LAST - 1,
+-};
+-
  #endif /* __LINUX_NL80211_H */
+--- a/info.c
++++ b/info.c
+@@ -701,7 +701,6 @@ broken_combination:
+               ext_feat_print(tb, OPERATING_CHANNEL_VALIDATION, "Operating Channel Validation (OCV) support");
+               ext_feat_print(tb, 4WAY_HANDSHAKE_AP_PSK, "AP mode PSK offload support");
+               ext_feat_print(tb, BSS_COLOR, "BSS coloring support");
+-              ext_feat_print(tb, FILS_CRYPTO_OFFLOAD, "FILS crypto offload");
+       }
+       if (tb_msg[NL80211_ATTR_COALESCE_RULE]) {
diff --git a/package/network/utils/iw/patches/010-Revert-iw-allow-specifying-CFLAGS-LIBS-externally.patch b/package/network/utils/iw/patches/010-Revert-iw-allow-specifying-CFLAGS-LIBS-externally.patch
new file mode 100644 (file)
index 0000000..1254efa
--- /dev/null
@@ -0,0 +1,68 @@
+From 1f3706d10812d70adefe32fe0d7d3a3ec25374f0 Mon Sep 17 00:00:00 2001
+From: Hauke Mehrtens <hauke@hauke-m.de>
+Date: Sun, 21 Nov 2021 00:02:57 +0100
+Subject: Revert "iw: allow specifying CFLAGS/LIBS externally"
+
+This reverts commit 1325244b77d56fd7a16d1e35fdae0efc151920b1.
+
+The OpenWrt build system provides the CFLAGS and LIBS names from the 
+package Makefile to overwrite them for libnl-tiny. This is not possible 
+after this upstream change which we revert here any more
+
+Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
+---
+ Makefile | 20 ++++++++++----------
+ 1 file changed, 10 insertions(+), 10 deletions(-)
+
+--- a/Makefile
++++ b/Makefile
+@@ -45,30 +45,30 @@ NLLIBNAME = libnl-1
+ endif
+ ifeq ($(NL2FOUND),Y)
+-override CFLAGS += -DCONFIG_LIBNL20
+-override LIBS += -lnl-genl
++CFLAGS += -DCONFIG_LIBNL20
++LIBS += -lnl-genl
+ NLLIBNAME = libnl-2.0
+ endif
+ ifeq ($(NL3xFOUND),Y)
+ # libnl 3.2 might be found as 3.2 and 3.0
+ NL3FOUND = N
+-override CFLAGS += -DCONFIG_LIBNL30
+-override LIBS += -lnl-genl-3
++CFLAGS += -DCONFIG_LIBNL30
++LIBS += -lnl-genl-3
+ NLLIBNAME = libnl-3.0
+ endif
+ ifeq ($(NL3FOUND),Y)
+-override CFLAGS += -DCONFIG_LIBNL30
+-override LIBS += -lnl-genl
++CFLAGS += -DCONFIG_LIBNL30
++LIBS += -lnl-genl
+ NLLIBNAME = libnl-3.0
+ endif
+ # nl-3.1 has a broken libnl-gnl-3.1.pc file
+ # as show by pkg-config --debug --libs --cflags --exact-version=3.1 libnl-genl-3.1;echo $?
+ ifeq ($(NL31FOUND),Y)
+-override CFLAGS += -DCONFIG_LIBNL30
+-override LIBS += -lnl-genl
++CFLAGS += -DCONFIG_LIBNL30
++LIBS += -lnl-genl
+ NLLIBNAME = libnl-3.1
+ endif
+@@ -76,8 +76,8 @@ ifeq ($(NLLIBNAME),)
+ $(error Cannot find development files for any supported version of libnl)
+ endif
+-override LIBS += $(shell $(PKG_CONFIG) --libs $(NLLIBNAME))
+-override CFLAGS += $(shell $(PKG_CONFIG) --cflags $(NLLIBNAME))
++LIBS += $(shell $(PKG_CONFIG) --libs $(NLLIBNAME))
++CFLAGS += $(shell $(PKG_CONFIG) --cflags $(NLLIBNAME))
+ endif # NO_PKG_CONFIG
+ ifeq ($(V),1)
index c50a4a4d38998e44c80a61ba4199d87daa623094..d0e837c69532c608954762745305d3e38eca9eaa 100644 (file)
@@ -38,7 +38,7 @@
  
 --- a/info.c
 +++ b/info.c
-@@ -216,6 +216,7 @@ next:
+@@ -215,6 +215,7 @@ next:
                                }
                        }
  
@@ -46,7 +46,7 @@
                        if (tb_band[NL80211_BAND_ATTR_RATES]) {
                        printf("\t\tBitrates (non-HT):\n");
                        nla_for_each_nested(nl_rate, tb_band[NL80211_BAND_ATTR_RATES], rem_rate) {
-@@ -232,6 +233,7 @@ next:
+@@ -231,6 +232,7 @@ next:
                                printf("\n");
                        }
                        }
@@ -54,7 +54,7 @@
                }
        }
  
-@@ -297,6 +299,7 @@ next:
+@@ -296,6 +298,7 @@ next:
                printf("\tCoverage class: %d (up to %dm)\n", coverage, 450 * coverage);
        }
  
@@ -62,7 +62,7 @@
        if (tb_msg[NL80211_ATTR_CIPHER_SUITES]) {
                int num = nla_len(tb_msg[NL80211_ATTR_CIPHER_SUITES]) / sizeof(__u32);
                int i;
-@@ -308,6 +311,7 @@ next:
+@@ -307,6 +310,7 @@ next:
                                        cipher_name(ciphers[i]));
                }
        }
  
        if (tb_msg[NL80211_ATTR_WIPHY_ANTENNA_AVAIL_TX] &&
            tb_msg[NL80211_ATTR_WIPHY_ANTENNA_AVAIL_RX])
-@@ -327,11 +331,13 @@ next:
-                       printf("\t\t * %s\n", iftype_name(nla_type(nl_mode)));
-       }
+@@ -324,9 +328,11 @@ next:
+               print_iftype_list("\tSupported interface modes", "\t\t",
+                                 tb_msg[NL80211_ATTR_SUPPORTED_IFTYPES]);
  
 +#ifdef IW_FULL
-       if (tb_msg[NL80211_ATTR_SOFTWARE_IFTYPES]) {
-               printf("\tsoftware interface modes (can always be added):\n");
-               nla_for_each_nested(nl_mode, tb_msg[NL80211_ATTR_SOFTWARE_IFTYPES], rem_mode)
-                       printf("\t\t * %s\n", iftype_name(nla_type(nl_mode)));
-       }
+       if (tb_msg[NL80211_ATTR_SOFTWARE_IFTYPES])
+               print_iftype_list("\tsoftware interface modes (can always be added)",
+                                 "\t\t", tb_msg[NL80211_ATTR_SOFTWARE_IFTYPES]);
 +#endif
  
        if (tb_msg[NL80211_ATTR_INTERFACE_COMBINATIONS]) {
                struct nlattr *nl_combi;
-@@ -428,6 +434,7 @@ broken_combination:
+@@ -416,6 +422,7 @@ broken_combination:
                        printf("\tinterface combinations are not supported\n");
        }
  
@@ -92,7 +90,7 @@
        if (tb_msg[NL80211_ATTR_SUPPORTED_COMMANDS]) {
                printf("\tSupported commands:\n");
                nla_for_each_nested(nl_cmd, tb_msg[NL80211_ATTR_SUPPORTED_COMMANDS], rem_cmd)
-@@ -525,6 +532,7 @@ broken_combination:
+@@ -513,6 +520,7 @@ broken_combination:
                                printf("\t\t * wake up on TCP connection\n");
                }
        }
  
        if (tb_msg[NL80211_ATTR_ROAM_SUPPORT])
                printf("\tDevice supports roaming.\n");
-@@ -563,6 +571,7 @@ broken_combination:
+@@ -551,6 +559,7 @@ broken_combination:
                }
        }
  
        if (tb_msg[NL80211_ATTR_FEATURE_FLAGS]) {
                unsigned int features = nla_get_u32(tb_msg[NL80211_ATTR_FEATURE_FLAGS]);
  
-@@ -627,6 +636,7 @@ broken_combination:
+@@ -615,6 +624,7 @@ broken_combination:
                if (features & NL80211_FEATURE_ND_RANDOM_MAC_ADDR)
                        printf("\tDevice supports randomizing MAC-addr in net-detect scans.\n");
        }
  
        if (tb_msg[NL80211_ATTR_TDLS_SUPPORT])
                printf("\tDevice supports T-DLS.\n");
-@@ -762,6 +772,7 @@ TOPLEVEL(list, NULL, NL80211_CMD_GET_WIP
+@@ -751,6 +761,7 @@ TOPLEVEL(list, NULL, NL80211_CMD_GET_WIP
         "List all wireless devices and their capabilities.");
  TOPLEVEL(phy, NULL, NL80211_CMD_GET_WIPHY, NLM_F_DUMP, CIB_NONE, handle_info, NULL);
  
  static int handle_commands(struct nl80211_state *state, struct nl_msg *msg,
                           int argc, char **argv, enum id_input id)
  {
-@@ -773,6 +784,7 @@ static int handle_commands(struct nl8021
+@@ -762,6 +773,7 @@ static int handle_commands(struct nl8021
  }
  TOPLEVEL(commands, NULL, NL80211_CMD_GET_WIPHY, 0, CIB_NONE, handle_commands,
         "list all known commands and their decimal & hex value");