ipq40xx: fix Edgecore ECW5211 boot
authorStijn Tintel <stijn@linux-ipv6.be>
Wed, 18 Aug 2021 13:11:11 +0000 (16:11 +0300)
committerStijn Tintel <stijn@linux-ipv6.be>
Wed, 18 Aug 2021 13:11:11 +0000 (16:11 +0300)
The bootloader will look for a configuration section named ap.dk01.1-c2
in the FIT image. If this doesn't exist, the device won't boot.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
target/linux/ipq40xx/image/generic.mk

index 9dee742eb4cd83b98b1de4e694ccfce838d546d7..c7e3583613ef085731eb9aa110f4fff662850db8 100644 (file)
@@ -365,6 +365,7 @@ define Device/edgecore_ecw5211
        SOC := qcom-ipq4018
        BLOCKSIZE := 128k
        PAGESIZE := 2048
+       DEVICE_DTS_CONFIG := config@ap.dk01.1-c2
        DEVICE_PACKAGES := kmod-tpm-i2c-atmel kmod-usb-acm
 endef
 TARGET_DEVICES += edgecore_ecw5211