uboot-bcm4908: use "xxd" from staging_dir
authorRafał Miłecki <rafal@milecki.pl>
Tue, 15 Mar 2022 11:40:40 +0000 (12:40 +0100)
committerRafał Miłecki <rafal@milecki.pl>
Tue, 15 Mar 2022 11:43:04 +0000 (12:43 +0100)
This fixes:
bash: xxd: command not found
on hosts without xxd installed.

Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
package/boot/uboot-bcm4908/Makefile

index 489b4d69bf668ab504d1dbd87c3643d64c1801e4..dc862f4e32df391ca850a71942d1cd73a1d92c89 100644 (file)
@@ -32,10 +32,10 @@ define Build/Prepare
        $(call Build/Prepare/Default)
        mkdir -p $(PKG_BUILD_DIR)/include/generated/
        ( cd $(PKG_BUILD_DIR)/board/broadcom/bcmbca/httpd/html/ && \
-         xxd -i index.html > ../../../../../include/generated/index.h && \
-         xxd -i flashing.html > ../../../../../include/generated/flashing.h && \
-         xxd -i fail.html > ../../../../../include/generated/fail.h && \
-         xxd -i 404.html > ../../../../../include/generated/404.h )
+         $(STAGING_DIR_HOST)/bin/xxd -i index.html > ../../../../../include/generated/index.h && \
+         $(STAGING_DIR_HOST)/bin/xxd -i flashing.html > ../../../../../include/generated/flashing.h && \
+         $(STAGING_DIR_HOST)/bin/xxd -i fail.html > ../../../../../include/generated/fail.h && \
+         $(STAGING_DIR_HOST)/bin/xxd -i 404.html > ../../../../../include/generated/404.h )
 endef
 
 define Build/InstallDev