kernel: kmod-xfrm-interface requires IPv6
authorStijn Tintel <stijn@linux-ipv6.be>
Fri, 12 Mar 2021 12:50:56 +0000 (14:50 +0200)
committerStijn Tintel <stijn@linux-ipv6.be>
Thu, 5 Aug 2021 21:21:08 +0000 (00:21 +0300)
The xfrm_interface module will not be built if IPv6 is not enabled in
the kernel. Add this dependency in the kmod package to avoid people
wondering why it doesn't build when they disabled IPv6.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
package/kernel/linux/modules/netsupport.mk

index 1eec9f9b639770750002a8510bd1df86c598cc52..62d79db51e1bfb4639950db9655e14b748c7e067 100644 (file)
@@ -375,7 +375,7 @@ $(eval $(call KernelPackage,ip6-vti))
 define KernelPackage/xfrm-interface
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=IPsec XFRM Interface
-  DEPENDS:=+kmod-ipsec4 +IPV6:kmod-ipsec6
+  DEPENDS:=@IPV6 +kmod-ipsec4 +kmod-ipsec6
   KCONFIG:=CONFIG_XFRM_INTERFACE
   FILES:=$(LINUX_DIR)/net/xfrm/xfrm_interface.ko
   AUTOLOAD:=$(call AutoProbe,xfrm_interface)