ath79: ZTE MF286R: add comgt-ncm to DEVICE_PACKAGES
authorLech Perczak <lech.perczak@gmail.com>
Sat, 23 Apr 2022 09:22:50 +0000 (11:22 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 23 Apr 2022 18:46:25 +0000 (20:46 +0200)
When adding support to the router's built-in modem, this required
package was omitted, because it was already enabled in the image
configuration in use for testing, and this went unnoticed.
In result, the modem still isn't fully supported in official images.
As it is the primary WAN interface, add the missing package.

Fixes: e02fb42c53ba ("comgt: support ZTE MF286R modem")
Signed-off-by: Lech Perczak <lech.perczak@gmail.com>
target/linux/ath79/image/nand.mk

index 0cf8f331d521e9a05837227ec1107ba23cb85f20..726fab068fcd3b8ed92d098b1c8c3208ba7adf1d 100644 (file)
@@ -334,7 +334,8 @@ TARGET_DEVICES += zte_mf286a
 define Device/zte_mf286r
   $(Device/zte_mf286_common)
   DEVICE_MODEL := MF286R
-  DEVICE_PACKAGES += ath10k-firmware-qca9888-ct kmod-usb-net-rndis kmod-usb-acm
+  DEVICE_PACKAGES += ath10k-firmware-qca9888-ct kmod-usb-net-rndis kmod-usb-acm \
+       comgt-ncm
 endef
 TARGET_DEVICES += zte_mf286r