ipq40xx: 5.15: refresh kernel patches
authorAnsuel Smith <ansuelsmth@gmail.com>
Sun, 27 Mar 2022 22:12:55 +0000 (00:12 +0200)
committerSungbo Eo <mans0n@gorani.run>
Sun, 1 May 2022 04:40:13 +0000 (13:40 +0900)
Refresh kernel patches.

Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
Reviewed-by: Robert Marko <robert.marko@sartura.hr>
13 files changed:
target/linux/ipq40xx/patches-5.15/104-clk-fix-apss-cpu-overclocking.patch
target/linux/ipq40xx/patches-5.15/300-clk-qcom-ipq4019-add-ess-reset.patch
target/linux/ipq40xx/patches-5.15/302-arm-compressed-set-ipq40xx-watchdog-to-allow-boot.patch
target/linux/ipq40xx/patches-5.15/400-mmc-sdhci-sdhci-msm-use-sdhci_set_clock-instead-of-s.patch
target/linux/ipq40xx/patches-5.15/420-firmware-qcom-scm-disable-SDI.patch
target/linux/ipq40xx/patches-5.15/421-firmware-qcom-scm-cold-boot-address.patch
target/linux/ipq40xx/patches-5.15/703-net-IPQ4019-needs-rfs-vlan_tag-callbacks-in.patch
target/linux/ipq40xx/patches-5.15/705-net-add-qualcomm-ar40xx-phy.patch
target/linux/ipq40xx/patches-5.15/707-net-phy-Add-Qualcom-QCA807x-driver.patch
target/linux/ipq40xx/patches-5.15/850-soc-add-qualcomm-syscon.patch
target/linux/ipq40xx/patches-5.15/900-dts-ipq4019-ap-dk01.1.patch
target/linux/ipq40xx/patches-5.15/901-arm-boot-add-dts-files.patch
target/linux/ipq40xx/patches-5.15/902-dts-ipq4019-ap-dk04.1.patch

index 25a2020bd26e07e6742f40221705ff55fb577e27..2de03f7ae0aff2cc2ba59108fb3c09fd843be02a 100644 (file)
@@ -83,16 +83,16 @@ Signed-off-by: John Crispin <john@phrozen.org>
        if (!f)
                return -EINVAL;
  
-@@ -1278,7 +1301,7 @@ static int clk_cpu_div_set_rate(struct c
+@@ -1277,7 +1300,7 @@ static int clk_cpu_div_set_rate(struct c
+       const struct freq_tbl *f;
        u32 mask;
-       int ret;
  
 -      f = qcom_find_freq(pll->freq_tbl, rate);
 +      f = qcom_find_freq_close(pll->freq_tbl, rate);
        if (!f)
                return -EINVAL;
  
-@@ -1305,6 +1328,7 @@ static unsigned long
+@@ -1304,6 +1327,7 @@ static unsigned long
  clk_cpu_div_recalc_rate(struct clk_hw *hw,
                        unsigned long parent_rate)
  {
@@ -100,7 +100,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
        struct clk_fepll *pll = to_clk_fepll(hw);
        u32 cdiv, pre_div;
        u64 rate;
-@@ -1325,7 +1349,11 @@ clk_cpu_div_recalc_rate(struct clk_hw *h
+@@ -1324,7 +1348,11 @@ clk_cpu_div_recalc_rate(struct clk_hw *h
        rate = clk_fepll_vco_calc_rate(pll, parent_rate) * 2;
        do_div(rate, pre_div);
  
index 4297f32e0516f5adc9be217a4e6f5d463c8be985..eb015251a1efb34a6f847763f894bd09cee60a59 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Ram Chandra Jangir <rjangir@codeaurora.org>
 
 --- a/drivers/clk/qcom/gcc-ipq4019.c
 +++ b/drivers/clk/qcom/gcc-ipq4019.c
-@@ -1736,6 +1736,17 @@ static const struct qcom_reset_map gcc_i
+@@ -1735,6 +1735,17 @@ static const struct qcom_reset_map gcc_i
        [GCC_TCSR_BCR] = {0x22000, 0},
        [GCC_MPM_BCR] = {0x24000, 0},
        [GCC_SPDM_BCR] = {0x25000, 0},
index 1aa5a9f38615656567dd4b93fb333daa8c56231a..51891c1f22794f6e86f7e43a320154eaf13cb5cc 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: John Thomson <git@johnthomson.fastmail.com.au>
 
 --- a/arch/arm/boot/compressed/head.S
 +++ b/arch/arm/boot/compressed/head.S
-@@ -602,6 +602,41 @@ not_relocated:    mov     r0, #0
+@@ -624,6 +624,41 @@ not_relocated:    mov     r0, #0
                bic     r4, r4, #1
                blne    cache_on
  
index fd46d54916a55618115a38700ceb387f0af15a7b..843291e871b74e111a22b7eaa82a8058540d6ada 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Robert Marko <robert.marko@sartura.hr>
 
 --- a/drivers/mmc/host/sdhci-msm.c
 +++ b/drivers/mmc/host/sdhci-msm.c
-@@ -2191,7 +2191,7 @@ MODULE_DEVICE_TABLE(of, sdhci_msm_dt_mat
+@@ -2445,7 +2445,7 @@ MODULE_DEVICE_TABLE(of, sdhci_msm_dt_mat
  
  static const struct sdhci_ops sdhci_msm_ops = {
        .reset = sdhci_msm_reset,
index eb474500b1b100423cf96e494f2f52d50ee0aaba..b2d7a403cfe542b7f2e7d516ebccd7ea18b1b3a2 100644 (file)
@@ -21,7 +21,7 @@
  static void qcom_scm_set_download_mode(bool enable)
  {
        bool avail;
-@@ -1256,6 +1270,13 @@ static int qcom_scm_probe(struct platfor
+@@ -1320,6 +1334,13 @@ static int qcom_scm_probe(struct platfor
        if (download_mode)
                qcom_scm_set_download_mode(true);
  
index accf3e968606b84e1b35653ec82b9c1f4018ee68..13ebb5b000aebea39f71acfad22876d0c834e62b 100644 (file)
@@ -34,7 +34,7 @@
 +}
 +
  /**
-  * qcom_scm_call() - Sends a command to the SCM and waits for the command to
+  * scm_legacy_call() - Sends a command to the SCM and waits for the command to
   * finish processing.
 @@ -160,10 +182,16 @@ int scm_legacy_call(struct device *dev,
  
index c0d99594da4c89e1822d1015392cf7e10933b51e..8825b07cdb5817ce8e1feaff5762ef7fae939c73 100644 (file)
@@ -24,7 +24,7 @@ Reviewed-by: Grant Grundler <grundler@chromium.org>
 
 --- a/include/linux/netdevice.h
 +++ b/include/linux/netdevice.h
-@@ -765,6 +765,16 @@ struct xps_map {
+@@ -771,6 +771,16 @@ struct xps_map {
  #define XPS_MIN_MAP_ALLOC ((L1_CACHE_ALIGN(offsetof(struct xps_map, queues[1])) \
         - sizeof(struct xps_map)) / sizeof(u16))
  
@@ -40,8 +40,8 @@ Reviewed-by: Grant Grundler <grundler@chromium.org>
 +#endif
  /*
   * This structure holds all XPS maps for device.  Maps are indexed by CPU.
-  */
-@@ -1445,6 +1455,9 @@ struct net_device_ops {
+  *
+@@ -1477,6 +1487,9 @@ struct net_device_ops {
                                                     const struct sk_buff *skb,
                                                     u16 rxq_index,
                                                     u32 flow_id);
index cd0b10c6c8a3f0fc007aa2f8313718e5df62d810..46d311a9b9fb43503c2c49978d7e4606879c9ab9 100644 (file)
@@ -1,8 +1,8 @@
 --- a/drivers/net/mdio/Kconfig
 +++ b/drivers/net/mdio/Kconfig
-@@ -27,6 +27,13 @@ config OF_MDIO
+@@ -41,6 +41,13 @@ config ACPI_MDIO
        help
-         OpenFirmware MDIO bus (Ethernet PHY) accessors
+         ACPI MDIO bus (Ethernet PHY) accessors
  
 +config AR40XX_PHY
 +   tristate "Driver for Qualcomm Atheros IPQ40XX switches"
  config MDIO_DEVRES
 --- a/drivers/net/mdio/Makefile
 +++ b/drivers/net/mdio/Makefile
-@@ -21,6 +21,8 @@ obj-$(CONFIG_MDIO_SUN4I)             += mdio-sun4i.
+@@ -23,6 +23,8 @@ obj-$(CONFIG_MDIO_SUN4I)             += mdio-sun4i.
  obj-$(CONFIG_MDIO_THUNDER)            += mdio-thunder.o
  obj-$(CONFIG_MDIO_XGENE)              += mdio-xgene.o
  
 +obj-$(CONFIG_AR40XX_PHY)              += ar40xx.o
 +
  obj-$(CONFIG_MDIO_BUS_MUX)            += mdio-mux.o
+ obj-$(CONFIG_MDIO_BUS_MUX_BCM6368)    += mdio-mux-bcm6368.o
  obj-$(CONFIG_MDIO_BUS_MUX_BCM_IPROC)  += mdio-mux-bcm-iproc.o
- obj-$(CONFIG_MDIO_BUS_MUX_GPIO)               += mdio-mux-gpio.o
index ba441022f320307d9df1e48ffc70307817c80c51..eba1d3454eab4241909f471d0c3c49614c29bec8 100644 (file)
@@ -25,7 +25,7 @@ Signed-off-by: Robert Marko <robert.marko@sartura.hr>
 
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -320,6 +320,12 @@ config AT803X_PHY
+@@ -346,6 +346,12 @@ config AT803X_PHY
          Currently supports the AR8030, AR8031, AR8033, AR8035 and internal
          QCA8337(Internal qca8k PHY) model
  
@@ -40,8 +40,8 @@ Signed-off-by: Robert Marko <robert.marko@sartura.hr>
        help
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -86,6 +86,7 @@ obj-$(CONFIG_MICROSEMI_PHY)  += mscc/
- obj-$(CONFIG_NATIONAL_PHY)    += national.o
+@@ -90,6 +90,7 @@ obj-$(CONFIG_NATIONAL_PHY)   += national.o
+ obj-$(CONFIG_NXP_C45_TJA11XX_PHY)     += nxp-c45-tja11xx.o
  obj-$(CONFIG_NXP_TJA11XX_PHY) += nxp-tja11xx.o
  obj-$(CONFIG_QSEMI_PHY)               += qsemi.o
 +obj-$(CONFIG_QCA807X_PHY)             += qca807x.o
index df0b70d72e108a4d134ffe1e356f18183c4e0c41..b39237b1ddd9ddd2c0a7aa9cd7324fc27cbb56dc 100644 (file)
@@ -12,7 +12,7 @@ Subject: SoC: add qualcomm syscon
  obj-$(CONFIG_QCOM_RPMHPD) += rpmhpd.o
 --- a/drivers/soc/qcom/Kconfig
 +++ b/drivers/soc/qcom/Kconfig
-@@ -189,6 +189,13 @@ config QCOM_SOCINFO
+@@ -190,6 +190,13 @@ config QCOM_SOCINFO
         Say yes here to support the Qualcomm socinfo driver, providing
         information about the SoC to user space.
  
index 5a245eb431369272635d257551152238d7f3671a..650bdafe0e632db46e76236d3ab5b79e8df3aab9 100644 (file)
 +              };
 +
                rng@22000 {
-                       status = "ok";
+                       status = "okay";
                };
 @@ -74,14 +101,6 @@
                        pinctrl-names = "default";
-                       status = "ok";
+                       status = "okay";
                        cs-gpios = <&tlmm 54 0>;
 -
 -                      mx25l25635e@0 {
@@ -58,7 +58,7 @@
                serial@78af000 {
 @@ -109,5 +128,41 @@
                wifi@a800000 {
-                       status = "ok";
+                       status = "okay";
                };
 +
 +              mdio@90000 {
index 671df84c59faa0431fae75adb277cb9d8deffb37..af1c695c26f04019c8a0a9767ceb72b45416474f 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -902,11 +902,65 @@ dtb-$(CONFIG_ARCH_QCOM) += \
+@@ -951,11 +951,75 @@ dtb-$(CONFIG_ARCH_QCOM) += \
        qcom-ipq4018-ap120c-ac.dtb \
        qcom-ipq4018-ap120c-ac-bit.dtb \
        qcom-ipq4018-jalapeno.dtb \
@@ -85,4 +85,4 @@ Signed-off-by: John Crispin <john@phrozen.org>
 +      qcom-ipq4029-mr33.dtb \
        qcom-ipq8064-ap148.dtb \
        qcom-ipq8064-rb3011.dtb \
-       qcom-msm8660-surf.dtb \
+       qcom-msm8226-samsung-s3ve3g.dtb \
index ca321448466983abcfeffdeede87cb78859ecbac..05778a638f84a6a1bc61edce3c82b4a6b2251e71 100644 (file)
                };
  
 @@ -89,11 +115,11 @@
-                       status = "ok";
+                       status = "okay";
                        cs-gpios = <&tlmm 12 0>;
  
 -                      m25p80@0 {