trusted-firmware-a.mk: make sure include directory exists
authorDaniel Golle <daniel@makrotopia.org>
Sat, 9 Apr 2022 21:00:50 +0000 (22:00 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Sat, 9 Apr 2022 21:24:36 +0000 (22:24 +0100)
ARM Trusted Firmware builds do not depend on any target libraries as
they are bare-metal builds. However, the compiler aborts due to
-Werror=missing-include-dirs if the include dir doesn't exists and this
can happen when building with parallelisation as that makes it likely
for arm-trusted-firmware-* to be build very early before any of the
libraries which would implicitely create the directory.
Fix this by making sure the include dir exists before building.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
include/trusted-firmware-a.mk

index dd740c45f26d415ecf57d19d0e87b9c4d3e5792b..d95250452b14b12a9efd3262a3bf164fa6c1bfbc 100644 (file)
@@ -68,6 +68,9 @@ define Build/Trusted-Firmware-A/Target
   endef
 endef
 
+define Build/Configure/Trusted-Firmware-A
+       $(INSTALL_DIR) $(STAGING_DIR)/usr/include
+endef
 
 define Build/Compile/Trusted-Firmware-A
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \