build: image: explicitly pass --rootfs to append-ubi
authorRobert Marko <robimarko@gmail.com>
Mon, 20 Sep 2021 10:16:42 +0000 (12:16 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 28 Nov 2021 16:17:22 +0000 (17:17 +0100)
Rootfs is now optional in ubinize-image.sh and
requires --rootfs flag instead of just passing the
rootfs image as the argument before ubinize opts.

So, simply add --rootfs flag before the $(IMAGE_ROOTFS).

Signed-off-by: Robert Marko <robimarko@gmail.com>
include/image-commands.mk

index 23c7bd6133dfceb173693720b81e6fd09a8fb6c4..4b5ff36ebeebfb89cc57836780b5876f30fe6c1c 100644 (file)
@@ -112,7 +112,7 @@ define Build/append-ubi
                $(if $(UBOOTENV_IN_UBI),--uboot-env) \
                $(if $(KERNEL_IN_UBI),--kernel $(IMAGE_KERNEL)) \
                $(foreach part,$(UBINIZE_PARTS),--part $(part)) \
-               $(IMAGE_ROOTFS) \
+               --rootfs $(IMAGE_ROOTFS) \
                $@.tmp \
                -p $(BLOCKSIZE:%k=%KiB) -m $(PAGESIZE) \
                $(if $(SUBPAGESIZE),-s $(SUBPAGESIZE)) \