base-files: fix option to make /var persistent
authorStijn Tintel <stijn@linux-ipv6.be>
Mon, 23 Aug 2021 11:06:35 +0000 (14:06 +0300)
committerStijn Tintel <stijn@linux-ipv6.be>
Mon, 23 Aug 2021 11:09:42 +0000 (14:09 +0300)
The option was initially named TARGET_ROOTFS_LN_VAR_TMP, and the check
was correct. When renaming the option to something more suitable, the
check was changed to check for n, but when an option is not set, it's
not n but empty. This results in the check always evaluating to false.
Fix the check by checking for y with ifneq.

Fixes: 57807f50ded6 ("base-files: add option to make /var persistent")
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
package/base-files/Makefile

index 6da3df2b4ea775bb420d00c8955818c5a393360b..58ad08c63a082b0b3812cb2e5a249f1e1932c1c7 100644 (file)
@@ -181,7 +181,7 @@ define Package/base-files/install
        mkdir -p $(1)/www
        mkdir -p $(1)/root
        $(LN) /proc/mounts $(1)/etc/mtab
-ifeq ($(CONFIG_TARGET_ROOTFS_PERSIST_VAR),n)
+ifneq ($(CONFIG_TARGET_ROOTFS_PERSIST_VAR),y)
        rm -f $(1)/var
        $(LN) tmp $(1)/var
 else