bcm4908: start working on Netgear RAXE500 image
authorRafał Miłecki <rafal@milecki.pl>
Fri, 19 Nov 2021 13:32:59 +0000 (14:32 +0100)
committerRafał Miłecki <rafal@milecki.pl>
Fri, 19 Nov 2021 13:45:47 +0000 (14:45 +0100)
bootfs still needs more work before it's ready.

For some unknown reason model RAXE500 uses board id RAX220.

Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
target/linux/bcm4908/image/Makefile
target/linux/bcm4908/image/bootfs-generic.its

index 8829e64ca153d133cae2133bf6fbf561747f4ce2..9ec42d062db3c7f03b9577333109aa3845ea4b15 100644 (file)
@@ -107,4 +107,20 @@ define Device/tplink_archer-c2300-v1
 endef
 TARGET_DEVICES += tplink_archer-c2300-v1
 
+define Device/netgear
+  DEVICE_VENDOR := NETGEAR
+  KERNEL := kernel-bin | bootfs
+  IMAGES := chk
+  IMAGE/chk := append-rootfs | pkgtb
+  NETGEAR_REGION := 1
+endef
+
+define Device/netgear_raxe500
+  DEVICE_MODEL := RAXE500
+  $(Device/netgear)
+  PKGTB_ITS := pkgtb-bcm4908.its
+  NETGEAR_BOARD_ID := U12H449T00_NETGEAR
+endef
+# TARGET_DEVICES += netgear_raxe500
+
 $(eval $(call BuildImage))
index d2f19ed7523f84e09294bef7c96cb6a59c98e9a3..6d8b3394ae1184cc2b3fa5466b3f395241c2e097 100644 (file)
                                algo = "sha256";
                        };
                };
+
+               fdt_linux_RAX220 {
+                       description = "dtb";
+                       data = /incbin/("${dts_dir}/broadcom/bcm4908/bcm4908-netgear-raxe500.dtb");
+                       arch = "arm64";
+                       type = "flat_dt";
+                       compression = "none";
+
+                       hash-1 {
+                               algo = "sha256";
+                       };
+               };
+       };
+
+       configurations {
+               conf_lx_RAX220 {
+                       description = "BRCM 63xxx linux";
+                       kernel = "kernel";
+                       fdt = "fdt_linux_RAX220";
+               };
        };
 };