include/meson: fix host build directory
authorRosen Penev <rosenp@gmail.com>
Mon, 31 Jan 2022 02:52:15 +0000 (18:52 -0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 6 Feb 2022 23:03:27 +0000 (00:03 +0100)
When using a non default MESON_HOST_BUILD_DIR, HOST_BUILD_DIR is not
appropriate to use. This change matches the target configure section.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
include/meson.mk

index e101de4d891a5d1ae4c8fff144b8fd5aac9420b9..102e74b542749afd48255f397008c9a4186e6969 100644 (file)
@@ -98,7 +98,7 @@ define Host/Configure/Meson
                --native-file $(HOST_BUILD_DIR)/openwrt-native.txt \
                $(MESON_HOST_ARGS) \
                $(MESON_HOST_BUILD_DIR) \
-               $(HOST_BUILD_DIR), \
+               $(MESON_HOST_BUILD_DIR)/.., \
                $(MESON_HOST_VARS))
 endef