kernel: fix name of CONFIG_SND_SOC_GENERIC_DMAENGINE_PCM
authorAndre Heider <a.heider@gmail.com>
Tue, 8 Oct 2019 18:06:57 +0000 (20:06 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 11 Oct 2020 15:45:02 +0000 (17:45 +0200)
CONFIG_SND_SOC_DMAENGINE_PCM was removed and replaced with
CONFIG_SND_SOC_GENERIC_DMAENGINE_PCM seven years ago, see:
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=28c4468b00a1e55e08cc20117de968f7c6275441
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=b7ae6f31d8243ec684af16bc5c763eccdfabaec0

Signed-off-by: Andre Heider <a.heider@gmail.com>
package/kernel/linux/modules/sound.mk

index f975103e508cb96c110cbc6b24c410bc125cdb05..faee6043dcb839e09a04735673a0a25ff83546fe 100644 (file)
@@ -191,10 +191,10 @@ define KernelPackage/sound-soc-core
   KCONFIG:= \
        CONFIG_SND_SOC \
        CONFIG_SND_SOC_ADI=n \
-       CONFIG_SND_SOC_DMAENGINE_PCM=y \
+       CONFIG_SND_SOC_GENERIC_DMAENGINE_PCM=y \
        CONFIG_SND_SOC_ALL_CODECS=n
   FILES:=$(LINUX_DIR)/sound/soc/snd-soc-core.ko
-  AUTOLOAD:=$(call AutoLoad,55, snd-soc-core)
+  AUTOLOAD:=$(call AutoLoad,55,snd-soc-core)
   $(call AddDepends/sound)
 endef