build: toplevel.mk: fix missing kconfig dependency tracking
authorPetr Štetiar <ynezz@true.cz>
Mon, 21 Feb 2022 10:50:39 +0000 (11:50 +0100)
committerPetr Štetiar <ynezz@true.cz>
Tue, 22 Feb 2022 15:37:23 +0000 (16:37 +0100)
Toplevel Make is not aware about changes in the `scripts/config/*conf`
targets and this is causing issues for during update to that part of
build tree, where one needs to handle this manually by either force
rebuilding the targets or running `make config-clean`. Fix this by
forcing the rebuild if necessary.

Fixes: #9297
Signed-off-by: Petr Štetiar <ynezz@true.cz>
include/toplevel.mk

index 1e543ebcb98f3fd2cdc2a7c21b21aa59b115ba3d..ce744bc92ccf6713adea67f3ad15a1622c9ca935 100644 (file)
@@ -101,7 +101,7 @@ ifneq ($(DISTRO_PKG_CONFIG),)
 scripts/config/%onf: export PATH:=$(dir $(DISTRO_PKG_CONFIG)):$(PATH)
 endif
 scripts/config/%onf: CFLAGS+= -O2
-scripts/config/%onf:
+scripts/config/%onf: FORCE
        @$(_SINGLE)$(SUBMAKE) $(if $(findstring s,$(OPENWRT_VERBOSE)),,-s) \
                -C scripts/config $(notdir $@)