rampis: use lzma-loader for ZTE MF283+
authorLech Perczak <lech.perczak@gmail.com>
Sun, 28 Feb 2021 02:24:19 +0000 (03:24 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 19 Mar 2021 00:25:26 +0000 (01:25 +0100)
Without that, after merging support to master, the device fails to boot
due to LZMA decompression error:

3: System Boot system code via Flash.
## Booting image at bc080000 ...
raspi_read: from:80000 len:40
.   Image Name:   MIPS OpenWrt Linux-5.4.99
   Created:      2021-02-25  23:35:00 UTC
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    1786664 Bytes =  1.7 MB
   Load Address: 80000000
   Entry Point:  80000000
raspi_read: from:80040 len:1b4328
............................   Verifying Checksum ... OK
   Uncompressing Kernel Image ... LZMA ERROR 1 - must RESET board to recover

Use lzma-loader to fix it.

Fixes: 59d065c9f81c ("ramips: add support for ZTE MF283+")
Signed-off-by: Lech Perczak <lech.perczak@gmail.com>
target/linux/ramips/image/rt305x.mk

index 30c9b0154ad07464ea413b657dcea3a34ec1f9d0..a3ce013fa21c1b6adaf7fb72b453711e46d797d0 100644 (file)
@@ -1184,6 +1184,7 @@ endef
 TARGET_DEVICES += zorlik_zl5900v2
 
 define Device/zte_mf283plus
+  $(Device/uimage-lzma-loader)
   SOC := rt3352
   IMAGE_SIZE := 15872k
   DEVICE_VENDOR := ZTE