ipq40xx: fix boards being shown twice
authorRobert Marko <robert.marko@sartura.hr>
Thu, 21 Jan 2021 12:08:57 +0000 (13:08 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Thu, 21 Jan 2021 16:08:16 +0000 (17:08 +0100)
Since generic images have been split to their own
Makefile boards are showing up twice in menuconfig
as $(eval $(call BuildImage)) was not dropped from
the new generic.mk.

Hence $(eval $(call BuildImage)) was being called
twice.

So, lets simply drop it from generic.mk.

Fixes: 378c7ff28210 ("ipq40xx: split generic images into own file")
Signed-off-by: Robert Marko <robert.marko@sartura.hr>
target/linux/ipq40xx/image/generic.mk

index 9cd50e23ffb632eadf87ffcb47bfd2bc23cdd2a6..4e40b8be50ed5977ace0f72eb5cb2f0803287ced 100644 (file)
@@ -805,5 +805,3 @@ define Device/zyxel_wre6606
        DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
 endef
 TARGET_DEVICES += zyxel_wre6606
-
-$(eval $(call BuildImage))