x86: add nforce eth to default packages
authorAlberto Bursi <bobafetthotmail@gmail.com>
Fri, 10 Apr 2020 20:45:19 +0000 (22:45 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 13 Apr 2020 20:41:37 +0000 (22:41 +0200)
forcedeth is necessary to use the integrated
ethernet controller of Nvidia nForce chipset.

There are PC motherboards with this chipset
from 2001 that run 32bit Athlon XP CPUs and
more modern ones up to 2009 that can run Intel
and AMD 64bit processors, so add this to
all non-geode x86 targets.

Signed-off-by: Alberto Bursi <bobafetthotmail@gmail.com>
target/linux/x86/64/target.mk
target/linux/x86/image/generic.mk
target/linux/x86/image/legacy.mk

index 5dd0015a0372349bdf828a8c1cbf4d0e4ecace23..6f5f896c8b43045699ed768c39d9268b3b4a67fe 100644 (file)
@@ -1,6 +1,7 @@
 ARCH:=x86_64
 BOARDNAME:=x86_64
-DEFAULT_PACKAGES += kmod-button-hotplug kmod-e1000e kmod-e1000 kmod-r8169 kmod-igb kmod-bnx2
+DEFAULT_PACKAGES += kmod-button-hotplug kmod-e1000e kmod-e1000 kmod-r8169 \
+       kmod-igb kmod-bnx2 forcedeth
 
 define Target/Description
         Build images for 64 bit systems including virtualized guests.
index 65f73611842cca1d3e7820be89ee74e601e1786f..c1a3f8b2e572e240470275e5bb66e6fb70053c1c 100644 (file)
@@ -2,7 +2,7 @@ define Device/generic
   DEVICE_TITLE := Generic x86
   DEVICE_PACKAGES += kmod-3c59x kmod-8139too kmod-e100 kmod-e1000 kmod-natsemi \
        kmod-ne2k-pci kmod-pcnet32 kmod-r8169 kmod-sis900 kmod-tg3 \
-       kmod-via-rhine kmod-via-velocity
+       kmod-via-rhine kmod-via-velocity forcedeth
   GRUB2_VARIANT := generic
 endef
 TARGET_DEVICES += generic
index 9909341729693ea613675b1ed9ac847aa4424aec..9d6fa5e3871ac68b4d9d2747adf9c14b228047f1 100644 (file)
@@ -2,7 +2,7 @@ define Device/generic
   DEVICE_TITLE := Generic x86/legacy
   DEVICE_PACKAGES += kmod-3c59x kmod-8139too kmod-e100 kmod-e1000 \
        kmod-natsemi kmod-ne2k-pci kmod-pcnet32 kmod-r8169 kmod-sis900 \
-       kmod-tg3 kmod-via-rhine kmod-via-velocity
+       kmod-tg3 kmod-via-rhine kmod-via-velocity forcedeth
   GRUB2_VARIANT := legacy
 endef
 TARGET_DEVICES += generic