layerscape: restool: Remove build of manpages
authorHauke Mehrtens <hauke@hauke-m.de>
Tue, 28 Dec 2021 15:06:03 +0000 (16:06 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 28 Dec 2021 15:09:12 +0000 (16:09 +0100)
The build of the manpages needs the pandoc tool, this is not in the
minimal requirements of OpenWrt, just remove the build of the restool
manpage. This fixes the build on systems without pandoc like the OpenWrt build bots.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/network/utils/layerscape/restool/patches/remove-manpage.patch [new file with mode: 0644]

diff --git a/package/network/utils/layerscape/restool/patches/remove-manpage.patch b/package/network/utils/layerscape/restool/patches/remove-manpage.patch
new file mode 100644 (file)
index 0000000..5cb9e0a
--- /dev/null
@@ -0,0 +1,18 @@
+--- a/Makefile
++++ b/Makefile
+@@ -53,14 +53,13 @@ restool: $(OBJ)
+ %.1: %.md
+       pandoc --standalone --to man $^ -o $@
+-install: restool scripts/ls-main scripts/ls-append-dpl scripts/ls-debug scripts/restool_completion.sh $(MANPAGE)
++install: restool scripts/ls-main scripts/ls-append-dpl scripts/ls-debug scripts/restool_completion.sh
+       install -D -m 755 restool $(DESTDIR)$(bindir)/restool
+       install -D -m 755 scripts/ls-main $(DESTDIR)$(bindir)/ls-main
+       install -D -m 755 scripts/ls-append-dpl $(DESTDIR)$(bindir)/ls-append-dpl
+       install -D -m 755 scripts/ls-debug $(DESTDIR)$(bindir)/ls-debug
+       $(foreach symlink, $(RESTOOL_SCRIPT_SYMLINKS), sh -c "cd $(DESTDIR)$(bindir) && ln -sf ls-main $(symlink)" ;)
+       install -D -m 755 scripts/restool_completion.sh $(DESTDIR)$(bindir_completion)/restool
+-      install -m 0644 -D $(MANPAGE) $(call get_manpage_destination,$(MANPAGE))
+ clean:
+       rm -f $(OBJ) $(MANPAGE) \