kernel: Fix kmod-regmap split
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 27 Jan 2019 10:04:58 +0000 (11:04 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 27 Jan 2019 10:07:14 +0000 (11:07 +0100)
Two regmap dependencies were wrong, this patch fixes them.
This was detected by the build bots.

Fixes: fd5c16870169 ("kernel: Build: Split kmod-regmap")
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/brcm2708/modules.mk
target/linux/ramips/modules.mk

index 0788a6eda39074256a12da43c9419e407b1a1609..9696fe3b4c02081c217642d2a40917c608c3737b 100644 (file)
@@ -93,7 +93,8 @@ define KernelPackage/sound-soc-3dlab-nano-player
   AUTOLOAD:=$(call AutoLoad,68,snd-soc-3dlab-nano-player)
   DEPENDS:= \
        @LINUX_4_14 \
-       kmod-sound-soc-bcm2835-i2s
+       kmod-sound-soc-bcm2835-i2s \
+       +kmod-regmap-i2c
 endef
 
 define KernelPackage/sound-soc-3dlab-nano-player/description
index 36f46e2b3515b60860698511e5fa2cb65c66d122..b604110b1e3953166ce13816dbafdfc23fc099be 100644 (file)
@@ -116,7 +116,7 @@ $(eval $(call KernelPackage,hsdma-mtk))
 
 define KernelPackage/sound-mt7620
   TITLE:=MT7620 PCM/I2S Alsa Driver
-  DEPENDS:=@TARGET_ramips +kmod-sound-soc-core +kmod-regmap-mmio +kmod-dma-ralink @!TARGET_ramips_rt288x
+  DEPENDS:=@TARGET_ramips +kmod-sound-soc-core +kmod-regmap-i2c +kmod-dma-ralink @!TARGET_ramips_rt288x
   KCONFIG:= \
        CONFIG_SND_RALINK_SOC_I2S \
        CONFIG_SND_SIMPLE_CARD \