kernel: define THERMAL_EMERGENCY_POWEROFF_DELAY_MS
authorStijn Tintel <stijn@linux-ipv6.be>
Tue, 19 Jun 2018 17:58:51 +0000 (20:58 +0300)
committerStijn Tintel <stijn@linux-ipv6.be>
Thu, 21 Jun 2018 17:02:22 +0000 (20:02 +0300)
Enabling CONFIG_ATH10K_THERMAL on targets that don't have CONFIG_THERMAL
enabled in their kernel config causes build to fail due to missing
symbol THERMAL_EMERGENCY_POWEROFF_DELAY_MS. Add it to kmod-thermal.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
package/kernel/linux/modules/other.mk

index 3a997f881e061a0689be815c1462ff5e32cdd22b..7e18a21db3df45fe6fd00b53b66af1c975799ec5 100644 (file)
@@ -927,6 +927,7 @@ define KernelPackage/thermal
        CONFIG_THERMAL_DEFAULT_GOV_STEP_WISE=y \
        CONFIG_THERMAL_DEFAULT_GOV_FAIR_SHARE=n \
        CONFIG_THERMAL_DEFAULT_GOV_USER_SPACE=n \
+       CONFIG_THERMAL_EMERGENCY_POWEROFF_DELAY_MS=0 \
        CONFIG_THERMAL_GOV_FAIR_SHARE=n \
        CONFIG_THERMAL_GOV_STEP_WISE=y \
        CONFIG_THERMAL_GOV_USER_SPACE=n \