octeon: split up DEVICE_TITLE
authorMoritz Warning <moritzwarning@web.de>
Sun, 14 Jul 2019 08:34:19 +0000 (10:34 +0200)
committerAlexander Couzens <lynxis@fe80.eu>
Fri, 2 Aug 2019 20:45:02 +0000 (22:45 +0200)
Splits up DEVICE_TITLE into DEVICE_VENDOR, DEVICE_MODEL and DEVICE_VARIANT.

Signed-off-by: Moritz Warning <moritzwarning@web.de>
target/linux/octeon/image/Makefile

index 299e9ba3965435acb8a00d7cefc02a5df79ccb80..c14aa27a2b8fde053e2da18dba8ea1bc85049e58 100644 (file)
@@ -30,15 +30,17 @@ TARGET_DEVICES += generic
 
 ER_CMDLINE:=-mtdparts=phys_mapped_flash:640k(boot0)ro,640k(boot1)ro,64k(eeprom)ro root=/dev/mmcblk0p2 rootfstype=squashfs,ext4 rootwait
 define Device/er
+  DEVICE_VENDOR := Ubiquiti
+  DEVICE_MODEL := EdgeRouter
   CMDLINE := $(ER_CMDLINE) 
-  DEVICE_TITLE := Ubiquiti EdgeRouter
 endef
 TARGET_DEVICES += er
 
 ERLITE_CMDLINE:=-mtdparts=phys_mapped_flash:512k(boot0)ro,512k(boot1)ro,64k(eeprom)ro root=/dev/sda2 rootfstype=squashfs,ext4 rootwait
 define Device/erlite
+  DEVICE_VENDOR := Ubiquiti
+  DEVICE_MODEL := EdgeRouter Lite
   CMDLINE := $(ERLITE_CMDLINE) 
-  DEVICE_TITLE := Ubiquiti EdgeRouter Lite
 endef
 TARGET_DEVICES += erlite