ramips: add MT7615 wireless support for ELECOM WRC-1167GHBK2-S
authorINAGAKI Hiroshi <musashino.open@gmail.com>
Thu, 27 Jun 2019 03:27:27 +0000 (12:27 +0900)
committerDaniel Golle <daniel@makrotopia.org>
Wed, 17 Jul 2019 12:45:18 +0000 (14:45 +0200)
ELECOM WRC-1167GHBK2-S has a MediaTek MT7615D chip for 2.4/5 GHz
wireless.

A driver package for MT7615 chip is added to OpenWrt in
a0e5ca4f3523b9eef96bff32e45f6fa8275b982f,
so add preliminary MT7615 chip support for WRC-1167GHBK2-S.

Note: Currently, DBDC mode for MT7615 is not supported in mt76 driver.

Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
target/linux/ramips/dts/mt7621_elecom_wrc-1167ghbk2-s.dts
target/linux/ramips/image/mt7621.mk

index 3a6eb7cec8758ab7af084d3eda9f2e9e4c38b609..cf5c9a2d24fa62c116af070512237a2e6e47eba6 100644 (file)
@@ -26,6 +26,7 @@
                wlan2g {
                        label = "wrc-1167ghbk2-s:white:wlan2g";
                        gpios = <&gpio0 3 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0radio";
                };
 
                wlan5g {
 
 &pcie {
        status = "okay";
-       /*
-        * WRC-1167GHBK2-S has MT7615D for 2.4/5 GHz wifi,
-        * but it's not supported in OpenWrt.
-        */
+};
+
+&pcie0 {
+       wifi@0,0 {
+               compatible = "mediatek,mt76";
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x0>;
+               mtd-mac-address = <&factory 0xe000>;
+               mtd-mac-address-increment = <1>;
+       };
 };
 
 &xhci {
index e2928c80ce1908e270306415b706f871d7a2b806..a48aedd661812feb6bdbf4900e867cea2fde6f0c 100644 (file)
@@ -181,6 +181,7 @@ define Device/elecom_wrc-1167ghbk2-s
   IMAGES += factory.bin
   IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) |\
     elecom-wrc-factory WRC-1167GHBK2-S 0.00
+  DEVICE_PACKAGES := kmod-mt7615e wpad-basic
 endef
 TARGET_DEVICES += elecom_wrc-1167ghbk2-s