ath79: add support for devolo WiFi pro 1750x
authorDavid Bauer <mail@david-bauer.net>
Tue, 11 Jun 2019 15:27:51 +0000 (17:27 +0200)
committerDavid Bauer <mail@david-bauer.net>
Sun, 14 Jul 2019 14:20:53 +0000 (16:20 +0200)
Hardware
--------
CPU:   Qualcomm Atheros QCA9558
RAM:   128M DDR2
FLASH: 16MiB
ETH:   1x Atheros AR8035 (PoE in)
WiFi2: QCA9558 3T3R
WiFi5: QCA9880 3T3R
BTN:   1x Reset
LED:   1x LED Power (non-controllable)
       1x LED Status (internal)
       1x LED LAN (controlled by PHY)
       1x LED WLAN
BEEP:  1x GPIO attached piezo beeper
UART:  3.3V GND TX RX (115200-N-8) (3.3V is square pad)
       Header is located next to external-LED header.

Installation
------------
Make sure you set a password for the root user as prompted on first
setup!

1. Upload OpenWRT sysupgrade image via SSH to the device.
Use /tmp as the destination folder on the device.
User is root, password the one set in the web interface.

2. Install OpenWRT with

> sysupgrade -n -F /tmp/<openwrt-image-name>

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/dts/qca9558_devolo_dvl1750x.dts [new file with mode: 0644]
target/linux/ath79/image/generic.mk

index 4aa9999947fe1eb0ece7948be807a5f64ff7e9b0..85e57c6eb5be1ba8c9c39a265db9c2e8dd99b428 100755 (executable)
@@ -14,6 +14,7 @@ ath79_setup_interfaces()
        devolo,dvl1200i|\
        devolo,dvl1750c|\
        devolo,dvl1750i|\
+       devolo,dvl1750x|\
        engenius,ecb1750|\
        glinet,ar300m-lite|\
        netgear,ex6400|\
index 2d4cfc8fd066a18a15f001827d3a7ed12633763f..06a48e2258c3b45bed045901933fe9846600a121 100644 (file)
@@ -91,7 +91,8 @@ case "$FIRMWARE" in
        devolo,dvl1200i|\
        devolo,dvl1750c|\
        devolo,dvl1750e|\
-       devolo,dvl1750i)
+       devolo,dvl1750i|\
+       devolo,dvl1750x)
                ath10kcal_extract "art" 20480 2116
                ath10kcal_patch_mac_crc $(macaddr_add $(mtd_get_mac_binary art 0) -1)
                ;;
diff --git a/target/linux/ath79/dts/qca9558_devolo_dvl1750x.dts b/target/linux/ath79/dts/qca9558_devolo_dvl1750x.dts
new file mode 100644 (file)
index 0000000..d0d678d
--- /dev/null
@@ -0,0 +1,53 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca9558_devolo_dvl1xxx.dtsi"
+
+/ {
+       compatible = "devolo,dvl1750x", "qca,qca9558";
+       model = "devolo WiFi pro 1750x";
+
+       aliases {
+               led-boot = &status_red;
+               led-failsafe = &status_red;
+               led-running = &status_red;
+               led-upgrade = &status_red;
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               status_red: status_red {
+                       /* This LED is not visible on the external casing. */
+                       label = "dvl1750x:red:status";
+                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+               };
+
+               wlan {
+                       label = "dvl1750x:green:wlan";
+                       gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0tpt";
+               };
+       };
+
+       beeper {
+               compatible = "gpio-beeper";
+               gpios = <&gpio 17 GPIO_ACTIVE_HIGH>;
+       };
+};
+
+&eth0 {
+       pll-data = <0xbe000000 0x80000101 0x80001313>;
+       phy-mode = "rgmii-id";
+};
+
+&gmac_config {
+       rxdv-delay = <3>;
+       rxd-delay = <3>;
+       txen-delay = <3>;
+       txd-delay = <3>;
+       rgmii-enabled = <1>;
+};
index b998cc4062b469adba5a2fa1e0250382b38f44ca..0836751e2a2821fdb50508377d7cac9d651a3f25 100644 (file)
@@ -263,6 +263,15 @@ define Device/devolo_dvl1750i
 endef
 TARGET_DEVICES += devolo_dvl1750i
 
+define Device/devolo_dvl1750x
+  ATH_SOC := qca9558
+  DEVICE_VENDOR := devolo
+  DEVICE_MODEL := WiFi pro 1750x
+  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+  IMAGE_SIZE := 15936k
+endef
+TARGET_DEVICES += devolo_dvl1750x
+
 define Device/dlink_dir-825-b1
   ATH_SOC := ar7161
   DEVICE_VENDOR := D-Link